Getting stuck at M logo during reboot

This is a discussion on Getting stuck at M logo during reboot within the Droid X Help forums, part of the Droid X Discussion category; Ever since putting boot strap and Froyo on my X every time I restart my phone freezes at the M logo. I have to do ...


+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
Like Tree2Likes

Thread: Getting stuck at M logo during reboot

  1. #1
    X Lurker Achievements:
    250 Experience Points3 months registered100 Experience Points31 days registered7 days registered
    sublime118's Avatar
    Member #
    860
    Join Date
    Jul 2010
    Posts
    24
    Liked
    0 times

    Getting stuck at M logo during reboot

    Ever since putting boot strap and Froyo on my X every time I restart my phone freezes at the M logo. I have to do a battery pull every time I reset it. Anything easy I can try to stop this? Thanks!

    Brian

  2. Droid X Forums
    Ads


  3. #2
    Rescue Squad
    Supporting Member
    Points: 32,688, Level: 100
    Level completed: 0%, Points required for next Level: 0
    Overall activity: 0%
    Achievements:
    7 days registeredTagger Second Class500 Experience Points250 Experience Points100 Experience Points
    DebianDog's Avatar
    Member #
    6359
    Join Date
    Aug 2010
    Location
    "The Sticks", Virginia
    Posts
    4,384
    Liked
    331 times
    If you install Bootstrap then used ROM manager to upgrade you will need to bootstrap again. <top button> At least that fixed my same issue.

  4. #3
    X Informant Achievements:
    3 months registered250 Experience Points31 days registered100 Experience Points7 days registered
    DroidWhat's Avatar
    Member #
    1497
    Join Date
    Jul 2010
    Location
    Ohio
    Posts
    73
    Liked
    2 times
    Yes, Bootstrap is the reason for this (happened to me). I just removed the bootstrap for now (delete /system/bin/hijack, delete /system/bin/logwrapper, renamed /system/bin/logwrapper.bin to /system/bin/logwrapper)

  5. #4
    How one would do that if they have only the Moto Logo on their screen as I do and only get to the 'bootloader 30.01' sreen when doing a 'pwr/vol/cam' button sequence after a battery pull.
    Pensacola32526 likes this.

  6. #5
    X Lurker Achievements:
    250 Experience Points3 months registered100 Experience Points31 days registered7 days registered
    Golfhunter28's Avatar
    Member #
    272
    Join Date
    Jul 2010
    Posts
    11
    Liked
    1 times
    Quote Originally Posted by hdokes View Post
    How one would do that if they have only the Moto Logo on their screen as I do and only get to the 'bootloader 30.01' sreen when doing a 'pwr/vol/cam' button sequence after a battery pull.
    This is exactly what happened to me and where I'm at. I tried to flash with SBF but it failed. Please tell us how to remove the bootstrap with only these two screens. Thanks

  7. #6
    *Rescue Squad*
    Supporting Member
    Points: 27,939, Level: 98
    Level completed: 59%, Points required for next Level: 411
    Overall activity: 0%
    Achievements:
    500 Experience Points250 Experience PointsTagger Second Class100 Experience Points7 days registered
    Abe21599's Avatar
    Member #
    16
    Join Date
    Jul 2010
    Location
    Ohio
    Posts
    4,864
    Liked
    459 times
    when the M logo freezes, pull the battery and it should boot normally. dont hold any buttons.

  8. #7
    X Lurker
    Points: 2,859, Level: 32
    Level completed: 73%, Points required for next Level: 41
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience Points100 Experience Points31 days registered7 days registered
    dipole's Avatar
    Member #
    1500
    Join Date
    Jul 2010
    Posts
    15
    Liked
    0 times
    Its there a more permanent fix than pulling the battery every time I reboot?

    Sent from my DROIDX using Tapatalk

  9. #8
    X Informant Achievements:
    3 months registered250 Experience Points31 days registered100 Experience Points7 days registered
    DroidWhat's Avatar
    Member #
    1497
    Join Date
    Jul 2010
    Location
    Ohio
    Posts
    73
    Liked
    2 times
    The simplest fix is to open up the Droid X Bootstrap and click the Bootstrap Recovery button. I am not sure but you may have to click the Reboot Recovery button too and from recovery just reboot and all should be well.

  10. #9
    X Lurker
    Points: 2,859, Level: 32
    Level completed: 73%, Points required for next Level: 41
    Overall activity: 0%
    Achievements:
    3 months registered250 Experience Points100 Experience Points31 days registered7 days registered
    dipole's Avatar
    Member #
    1500
    Join Date
    Jul 2010
    Posts
    15
    Liked
    0 times
    Thanks, but when I do this, it seems like it boots up twice? First to the recovery screen, then I need to reboot again? Just making sure that this is the process.....
    Is there anyway to skip the recovery screen at this point or do I just have to live with it?
    Quote Originally Posted by DroidWhat View Post
    The simplest fix is to open up the Droid X Bootstrap and click the Bootstrap Recovery button. I am not sure but you may have to click the Reboot Recovery button too and from recovery just reboot and all should be well.

  11. #10
    X Informant Achievements:
    3 months registered250 Experience Points31 days registered100 Experience Points7 days registered
    DroidWhat's Avatar
    Member #
    1497
    Join Date
    Jul 2010
    Location
    Ohio
    Posts
    73
    Liked
    2 times
    Yes, let it boot into recovery then select reboot and it should be fine after that (it should not boot into recovery again).

    If you look at my very first post in this thread i mentioned that i originally just removed the Bootstrap files and reverted back to the original logwrapper which this also fixed the issue too.

    I had lost root during my first update to Froyo so just went the easy route the second time (flash sbf, one click root, rom manager/bootstrap to install froyo). It seems the bootstrap gets kludged up causing this.

    **EDIT**... Need i mention that i re-installed bootstrap and it works fine. Its just that it appears after installing froyo the boot has this problem until you do this. At least for me it did.
    Last edited by DroidWhat; 08-22-2010 at 08:17 AM.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Similar Threads

  1. How do you manually reboot the Droid X?
    By Hephaestus in forum Droid X Help
    Replies: 11
    Last Post: 10-01-2011, 08:38 PM
  2. Resending SMS Text after Reboot
    By mnasholm in forum Droid X General Discussion
    Replies: 9
    Last Post: 07-05-2011, 11:51 PM
  3. X won't boot past M logo
    By fragar in forum Droid X Help
    Replies: 1
    Last Post: 11-17-2010, 07:53 PM
  4. Stuck at motorola logo...computer wont recognize phone
    By bill0405 in forum Droid X Help
    Replies: 11
    Last Post: 08-10-2010, 04:02 PM
  5. 7 days on the DX without a reboot.
    By tourrider in forum Droid X General Discussion
    Replies: 13
    Last Post: 07-23-2010, 12:25 AM

Search tags for this page

Motorola Cliq stuck on m logo
,
droid x frozen at the motorola logo
,
droid x frozen on motorola logo
,
droid x motorola logo stuck
,

droid x stuck at motorola logo

,
droid x stuck motorola logo
,
droid x stuck on moto logo
,

droid x stuck on motorola logo

,
stuck at motorola logo droid x
,
stuck on motorola logo droid x
Click on a term to search our sites for related topics.