View Full Version : Milestone X thinks it's a Droid X when I need it to be a MX.

07-30-2014, 12:05 AM
Now, before you start, "This has been posted tons of times. Ignored", may I clarify that every single method I've used doesn't 'fix' my problem entirely.
So, yeah. I was running CyanogenMod 11 (Not the one in DX forums; in XDA) and download Aero Control. I applied most of the recommended settings, since some weren't available, and rebooted. The phone went into bootloops and i was forced to go to TWRP and reflash the ROM, and the kernel, to see if it now worked. But TWRP says it can't mount into storage, and while the Internet is full of guides, the DX/MX doesn't have internal storage to which i can mount to. No matter, just went and downloaded the stuff needed (RSD Lite, DX firmware, etc). Sadly, after about 8 months of first flashing an SBF, i forgot RSD Lite was the devil when paired with .621. sd_shadow is gonna facepalm when he/she sees this. Long story short, I actually need that phone working with Open Mobile, my carrier, because in 2014, they still sell the Pantech Breakout (you know, the phone that broke the mold). By necessity, I bought it at an exceptional price with an even better off contract plan. But that BS (excuse the language) is worse that my LG RUMOR 2. Data drops, reboots, battery pulls, you name it. So that's where the Milestone comes in.

The thing is that, before i go to pay, I want to swap out the phones. If you need to know, i can call 611 and i hear their auto-voice. Both phones are original to the carrier, and if it weren't because they don't accept unlocked phones, i would have gotten the Moto G (specifically, the Moto 4G)

But until they update stock, I need a way to get a Milestone X stock ROM for my carrier to accept it. I need data most of all for school. Plus i got to show off with that beautiful build. Whatever you say, it will be thanked when i find out how to do it in the web :P

07-30-2014, 09:50 AM
so you have tried Blur_Version.4.5.604.MB809.ACG-nTelos.en.US or Blur_Version.4.5.604.MB809.ACG-Alltel.en.US?
Motorola Firmwares (http://sbf.droid-developers.org/phone.php?device=32)
just verify md5 checksum https://sites.google.com/site/sdshadowscollection/home/hash-checksums
verify motorola drivers Driver links / Errors (https://docs.google.com/document/d/1QZtlBNvzefJXL1QAM5FJWJWlXHmy4skwmya-XaTM5QE/edit#bookmark=id.c5ul4tk8ot9y) /verify drivers are installed correctly
(https://docs.google.com/document/d/1QZtlBNvzefJXL1QAM5FJWJWlXHmy4skwmya-XaTM5QE/edit#bookmark=id.abee10a1pgla)use rsd lite 5.7 or newer RSD Lite Downloads (https://sites.google.com/site/sdshadowscollection/home/rsd-lite)you need to use rsd lite to change radio to Milestone X
if you never used rsd lite to flash Droid X radio should be still Milestone X
Then just use 1KDStaz_MX_4.5.604.iso (http://forumfoundrycdn.com/1kds/Linux/MX/1KDStaz_MX_4.5.604.iso)
and follow instructions here http://www.droidxforums.com/forum/droid-x-sbf/23638-linux-solution-your-windows-rsd-lite-problems.html
or DX (MB810) ezSBF & Root 2.3.4/4.5.621 (https://docs.google.com/document/d/1V_meI1kibcU-yKrRwzhAuGKPEWCS0lOwNDgg2dOJOQw/edit#) just use 1KDStaz_MX_4.5.604.iso (http://forumfoundrycdn.com/1kds/Linux/MX/1KDStaz_MX_4.5.604.iso) instead of 621

07-30-2014, 10:14 AM
I did actually try the nTelos one you said, but then went back to VZW SBF via RSD Lite. But from what i understood, I can have the nTelos SBF, and I'll still get data, and so then I go to ezSBF/SliTaz and flash the Droid X's SBF and i can still have the same MX radio properties? Sounds legit.

What I'll do is do the above, and go to my carrier to ask about the switch. It may or may not be today, though, since I'm waiting for a battery for this little lady to arrive today. But Amazon did say they put that date because of one reason, and then they had to change it for another. That means $0. Nice.
BTW, don't you happpen to know where they sell that battery cover dirt cheap? $5 dollars is a bit harsh.

07-30-2014, 10:48 AM
If the nTelos radio is compatible with your carrier, that i do not know.
It is possible that Open Mobile had motorola custom flash the radio, or had a 3rd party flash it.
Most likely your local Open Mobile store has no idea about any of this.

07-30-2014, 11:10 AM
Pretty sure they don't lol.
I'm due today to pay them, so we'll see. May call their HQ.

I'm downloading the latest nTelos file from 1KDS since your file ha no mirrors and takes a lifetime. Using Download Accelerator Plus.

07-31-2014, 09:02 PM
Got access to a friends MX. Some stuff i got:

System version - 4.5.604.mb809.acg.en.us

Android version - 2.3.5

Baseband - BP_C_03.12.00R
mcbk83@il93lnxdroid08 #1

ERI version - 5

PRL version - 202

Sent from my ADR8995 using Tapatalk 2

07-31-2014, 09:04 PM
Compared to mine, only the system version (nTelos is on it) and PRL (mine is 21100) are different.What to do from here?

Sent from my ADR8995 using Tapatalk 2

07-31-2014, 10:19 PM
Guessing plr will change when it connects to CDMA network, should not need to worry about it.

system version should not affect how it works, maybe able to change last line in the /system/build.prop
with root browser's text editor
from 4.5.604.MB809.ACG-nTelos.en.US to 4.5.604.mb809.acg.en.us

Should be good unless your carrier requires some special radio settings, that are not shown

07-31-2014, 10:30 PM
I bet APNs are no problem, and i found out baseband is radio. Will try the build.prop thing after i root the poor thing. Thank you so much.

P.S. Can i call you 'pops'? :D

Sent from my ADR8995 using Tapatalk 2

07-31-2014, 10:38 PM
I bet APNs are no problem, and i found out baseband is radio. Will try the build.prop thing after i root the poor thing. Thank you so much.

P.S. Can i call you 'pops'? :D

Sent from my ADR8995 using Tapatalk 2Apns can be copied/created, with APN Backup & Restore (https://play.google.com/store/apps/details?id=com.riteshsahu.APNBackupRestore&hl=en) - Openmobile PR Carrier's APN (http://forum.xda-developers.com/showthread.php?t=1712996)
Baseband is base radio, but it does not show everything
if you edit build.prop, need to reboot to show changes