PDA

View Full Version : Is there a current tutorial for rooting and installing eclipse 2.3?



RugerRedhawk
11-05-2013, 02:58 PM
I have two droid x2s on the way and would like to start right off with rooting them and getting eclipse on there. All of the threads regarding this process seem to be bits and pieces here and there, and/or they contain old broken links to downloads. Just wondering if anyone would be kind enough to point me to a useful tutorial of the process. I like the sounds of eclipse because it seems to be the most stable available rom from what I've read. Thanks in advance.

sd_shadow
11-05-2013, 05:31 PM
phone need to be on system version 1.3.418
if yours is different please post it.
28512

phone needs to be rooted use
[How To] Root 2.3.5/1.3.418 (https://docs.google.com/document/d/10icoGLMINaviCt1dqVU14lt7-cfxM-46DiASJpGWIqs/edit) Magic MD5 Method

download BSR/Bootstrap Recovery MOTODX2_Bootstrap_signed.rar (http://d-h.st/JPN)
and eclipse 2.3 X2-Eclipse-v2.3.zip (http://d-h.st/5jU)
install following these excellent instructions
making backup is optional

Installing BSR
1. Download BSR onto your computer http://www.markhm1972.com/MotorolaDroidX2/MOTODX2_Bootstrap_signed.rar
2. unzip it and place it on your external sd card (with your phone in usb mass storage mode.)
3. on your phone go to Settings-->applications and make sure "unknown sources" is checked.
4. use your file manager app to locate it it
5. press it and choose package install, and install it.
6. you will now have an app called system recovery, open it and press "install recovery"

***Important: In order to enter BSR/System recovery YOU MUST BE PLUGGED INTO A WAll CHARGER, not the computer or anything else, A WALL CHARGER***

Make a backup
1. Once you are sure you are plugged into a wall charger press "Recovery Mode" inside the system recovery app and in a few seconds your phone should reboot into the recovery menu.
2. Once you are in the recovery menu press volume down 6 times and "backup & restore" should be selected. Press the power button on top of your phone to select it.
3. Use your volume buttons (up and down) to navigate to external sd card as storage location and select it using the power button.
4. On the next screen the "backup" option should already be highlighted so select it.
5. Backup will begin and should take no longer than 10 minutes.
6. After the backup is complete you should be back at the original bsr menu and "Reboot System Now" should be highlighted. Select it.
7. You have just successfully backed up your phone.

To Install Eclipse
1. Download eclipse on to your computer. Place the entire zip on your external SD card using USB mass storage mode. (not in a folder just on your card. Do not unzip it)
2. Important:Make sure any pictures you want to keep are stored on your external sd card because you will be doing a data wipe. Also just to be safe make sure your contacts are backed up through google or verizon just in case.
3. Again make sure you are plugged in to a wall charger and enter Recovery Mode again through system recovery
4. In the recovery menu go down and highlight "Wipe Data/Factory Reset" and select it.
5. Once that is complete go down and select "Install zip from SDCARD"
6. On the next screen select the second option "choose zip from sdcard"
7. Go down and highlight "X2-Eclipse-v2.3.zip" and select it.
8. Once that process is complete Reboot System Now
9. The first bootup will take the longest, so dont worry if the Eclipse Boot animation stays on screen for a little longer than normal.
10. Activate phone and enjoy eclipse.

Note: once Eclipse is installed your task manager and System recovery will be located under Settings--> Eclipse parts.

Also once Eclipse is successfully installed make another backup just in case something goes wrong down the road, you will have a fail safe.

http://www.droidxforums.com/forum/droid-x2-roms/46031-rom-eclipse-v2-2-5-7-12-a.html
also a general bsr video How to use bootstrap recovery (http://youtu.be/_5AHZPgIJSw)

RugerRedhawk
11-05-2013, 05:36 PM
Thank you this is very helpful, I'll report back with the system version when I get the phones in the mail.

RugerRedhawk
11-07-2013, 05:40 PM
Version number looks right, but the flash method just hangs on "* daemon started successfully *" on the PC indefinitely. Tried turning usb on and off bunch of times and tried various usb ports on the laptop.

RugerRedhawk
11-07-2013, 06:02 PM
Are there motorola drivers I'm supposed to put on my laptop?

edit: yup got the drivers for my pc and that did the trick! For anyone else who stumbles on this here is where I got the drivers: https://motorola-global-portal.custhelp.com/app/answers/detail/a_id/88481/action/auth

sd_shadow
11-07-2013, 06:06 PM
try Motorola_End_User_Driver_Installation_5.9.0
(http://d-h.st/users/twinkyz1979/?fld_id=4625#files)
edit: I'm not sure why I don't have a link to drivers, on my page

RugerRedhawk
11-07-2013, 08:02 PM
Thanks, recovery mode does not work... I downloaded a root check app and it says that I have root access. I clicked 'install recovery', then 'recovery mode', but it does nothing. Plugged into wall charger.

sd_shadow
11-07-2013, 08:05 PM
try power off, then connect to charger

Sent from my XT862 using Tapatalk

RugerRedhawk
11-07-2013, 08:20 PM
No luck, same issue on both units...

sd_shadow
11-07-2013, 08:22 PM
uninstall system recovery, redownload, and reinstall

Sent from my XT862 using Tapatalk

sd_shadow
11-07-2013, 08:25 PM
wait, did you install the bootstrap after rooting, or did you try using one installed during the root process?

Sent from my XT862 using Tapatalk

RugerRedhawk
11-07-2013, 08:43 PM
could it be that my root didn't take? Still same problem on both phones after re-download, uninstall, reinstall.... tried different wall chargers and different cables too.

sd_shadow
11-07-2013, 08:46 PM
if root basic said phone is rooted, it should be
did you use the 2013 or 2013v2 rooting file

Sent from my XT862 using Tapatalk

RugerRedhawk
11-07-2013, 08:48 PM
I downloaded the bootstrap recovery from your post and used that.... I'll double check the root using the tool you specified

sd_shadow
11-07-2013, 08:59 PM
if you rooted with 2013v2, bootstrap should have been installed while rooting, and installing bootstrap again may have caused problems
if you used the original 2013, you need to install bootstrap

sd_shadow
11-07-2013, 09:03 PM
I just added DX2Batchroot_2013.v2.exe (http://d-h.st/Aw3)
to my page yesterday

try opening supersu app, and wipe log
then reopen system recovery, and try again

RugerRedhawk
11-07-2013, 10:02 PM
Thanks a ton, I'm trying from the beginning using the v2 file, I had the regular 2013 root exe.

sd_shadow
11-07-2013, 10:05 PM
that wasn't what I was suggesting, but I would use the universal unroot (https://play.google.com/store/apps/details?id=com.universal.unroot) in app store before running new version

Sent from my XT862 using Tapatalk

sd_shadow
11-07-2013, 10:15 PM
are you verifying the md5 checksums for the files?

Sent from my XT862 using Tapatalk

RugerRedhawk
11-07-2013, 10:15 PM
Nice, got it working on phone number one. Re-ran the v2 root exe, then supersu acted like it was working. Now recovery app is rocking as expected.

sd_shadow
11-07-2013, 10:16 PM
good enough

Sent from my XT862 using Tapatalk