PDA

View Full Version : .621 one click root method on device!!



SWAG
04-24-2013, 07:41 PM
Wanted root acces and found this one click root app over on xda. [ROOT] Framaroot, a one-click application to root some devices - xda-developers (http://forum.xda-developers.com/showthread.php?t=2130276)

SWAG
04-25-2013, 02:09 AM
Yes i know that. But i tried anyway and ot worked.

sd_shadow
04-25-2013, 06:08 PM
correct it works

[ROOT] Framaroot, a one-click application to root
only 2.14 MB
(http://forum.xda-developers.com/showthread.php?t=2130276)

Dev-host mirror (http://d-h.st/fO5)
Google Drive mirror (https://docs.google.com/file/d/0B_nizg6yUZ0NZGd1RFYydGN1YTg/edit)-Tomsgt123 (https://sites.google.com/site/tomsgt123/all-videos/motorola-droid-x)

verify md5 (https://docs.google.com/document/d/1HXkPKkbHB-pda9MFmNU1SKJvle_XgUrDpzqka8r5_D8/edit):BAB54AEDA55867EB59884FF30507225A

I have verified it works with these Motorola devices running android 2.3.4
Droid 2 (a955), Droid 2 Global (a956), R2D2 (a957), & Droid X (MB810)

Just download, allow unknown sources, install, open, select top root method (Gimli), reboot phone, done, no pc needed


http://youtu.be/-5TmP15hfQU

change log
25 July 2013 added mirror

Nemo aeternamn
04-25-2013, 06:52 PM
moved back to droid x hacks because it works

GoCliffGo05
04-25-2013, 07:25 PM
Well that's pretty awesome. :thumbup:

Nice find SWAG, nice testing sd.

jhi
04-28-2013, 01:02 PM
So, I am new to this. I have a Droid X with exact configuration as the video. I installed framaroot, and did the same as video except installed superuser not superuser su. It worked but... The phone freezes every few minutes, if the screen times out it won't come back on. All I can do is pull the battery and reboot. I can then use the phone for a few minutes before it freezes again. I have un-rooted then uninstalled framaroot but problems are persisting. I have no idea what to do to get my phone back. Can anyone offer any suggestions?

sd_shadow
04-28-2013, 01:09 PM
I would flash SBF, with ezSBF 621 (http://www.droidxforums.com/forum/droid-x-hacks/47718-how-root-4-5-621-magic-md5-does-not-require-milestone-sbf.html) or rsd lite
(https://docs.google.com/document/d/1YIetNYlAAe2sgxlzKlMXqhoSXIC0f-0TVemquhtZtnE/edit)as to why you're having problems don't know
redownload framaroot and try again or just root with magic md5

(http://www.droidxforums.com/forum/droid-x-hacks/47718-how-root-4-5-621-magic-md5-does-not-require-milestone-sbf.html)edit: I have not tested the SuperSU option, as shown in video, just the superuser (default)

also verify md5 (https://docs.google.com/document/d/1HXkPKkbHB-pda9MFmNU1SKJvle_XgUrDpzqka8r5_D8/edit): BAB54AEDA55867EB59884FF30507225A

edit: I have tested SuperSU, and unroot options and they worked fine.

jhi
04-28-2013, 05:13 PM
OK. Followed your advice, used the rsd-lite. After going through the rsd lite process I wiped the cache in recovery because it still blacked out on me and had to do a hard reboot. I guess I jumped in and am a little out of my league. It does seem to be stable at the moment. It's been about 15 minutes without a freeze. Thank you. I may defer my ideas about rooting at the moment. In general do you root on a completely clean system? Perhaps that is the mistake I made?

sd_shadow
04-28-2013, 05:35 PM
did you verify md5 (https://docs.google.com/document/d/1HXkPKkbHB-pda9MFmNU1SKJvle_XgUrDpzqka8r5_D8/edit): BAB54AEDA55867EB59884FF30507225A
for Framaroot?
it is possible, a setting or app caused a conflict, what for sure is unknown(to me)

edit: I have tested SuperSU, and unroot options and they worked fine.

jhi
05-12-2013, 01:21 AM
sd_shadow, I wanted to update and apologize. Turns out it was a 32gb SD card that was causing the freeze-ups. The card works fine in other android phones but the Droid X doesn't like it. It was coincidental and took me a bit to figure out.

sd_shadow
05-12-2013, 01:40 AM
no problem,
32gb sd cards sometimes have caused problems, should be several threads on that.
have you tried reformating?
there some settings that can be changed to optimize the card, that may help
need an app like rom tool box

edit: try changing cache size to 1024 or 2048

By default, it may only be 128KB.
http://www.techrepublic.com/blog/tablets/increase-the-readwrite-speed-of-the-sd-card-on-your-rooted-android-tablet/226

tizoc
07-02-2013, 05:54 PM
I'm pretty concerned! I downloaded framaroot but when I follow the steps, it does not say successful, instead just closes the app... how can I fix this?
btw, I'm running 2.3.4

sd_shadow
07-02-2013, 05:58 PM
which system version?

edit: menu>settings >about phone> system version

Sent from my Amazon Kindle Fire using Tapatalk 2

tizoc
07-02-2013, 06:10 PM
all is the same as the video,
android 2.3.4
version 4.5.621

sd_shadow
07-02-2013, 07:26 PM
not sure, could the try several things
redownload framaroot / try a different version
safe mode
flash sbf
wipe data
magic md5 root method

links in my list
sd_shadow's [Collection] of Links for: Droid X (MB810) (https://docs.google.com/document/d/1QZtlBNvzefJXL1QAM5FJWJWlXHmy4skwmya-XaTM5QE/edit?usp=sharing)

Sent from my Amazon Kindle Fire using Tapatalk 2

Tylergerde
07-25-2013, 06:24 PM
hello there i am as well new to rooting... i have a droid x, 4.5.621. I am in fact a noob, but could someone lend me a finger? what file do i download.. for Framaroot. i have tried all of them and everyone says download unsuccessful, i tried downloading more then once, does it matter the browser you or i use. cause i use puffin. i dont think that it would but it could.. ??

please help- tyler

sd_shadow
07-25-2013, 06:48 PM
try this one
https://docs.google.com/file/d/0B_nizg6yUZ0NZGd1RFYydGN1YTg/edit?usp=sharing
if that doesn't work may need to factory reset

edit: if that link does not work may need to try stock browser or I can upload to a different site

Tylergerde
07-25-2013, 07:31 PM
thank you much! it worked i had to factory reset and it worked beautifully. thank you for the help

jimmiles
11-13-2013, 09:03 AM
I love you! So easy, and worked perfectly! (1.4.1 version, on DX, with .621). I owe you a million dollars.