View Full Version : Please help. Phone won't even boot into recovery :(

03-07-2013, 03:00 AM
I bought a Droid X off my sister today and when I received it the phone worked great.

After installing the OTA update to 2.3.4 (Verizon) and trying to unlock the bootloader and root the phone, I screwed up somewhere and I'm not sure where.

The red "M" doesn't show up either. When you power on the phone it simply displays the following:



Service Req'd
Battery OK
OK to Program
Connect USB
Data Cable


Please help! I've tried flashing an .sbf via rsdlite and although RSD reported a success of update, the phone continues to boot the the exact screen above. Won't even allow me to enter recovery, or even view it for that matter.

Phone won't charge, how do I fix this??


03-07-2013, 04:10 AM
Mem pack blanks means you are on .621 and tried to flash an earlier version. You'll need to sbf with .621. Let me find the file.

Edit: you are on Verizon right? If so use this https://sites.google.com/site/motosbf/droid-x-sbf-files

The file all the way at the bottom.

Sent from my DROID RAZR HD using Xparent Cyan Tapatalk 2

03-07-2013, 11:47 AM
Alright, I'm flashing now with rsdlite and I'm at 34%. Lets see what happens. UPDATE: Although I already flashed the phone with this exact SBF, I had to flash a different sbf first which got rid of any errors in bootloader, then I flashed the sbf you told me to which worked perfectly. THANKS!!!!!!!!

03-07-2013, 01:47 PM
Glad you are back up and running.

Sent from my DROID RAZR HD using Xparent Cyan Tapatalk 2