View Full Version : Droid X locked up; powered off and am unable to power back on

02-07-2013, 03:57 PM
Hello. My Droid X (original version--purchased on first day offered in
July 2010) won't power on. Yesterday I was editing a photo to save for
my background when the phone froze. I powered off and now I can't get it
to complete powering on. The green light is flashing. I held down the
power on button and got the red circle with the M followed by the
droid/mercury graphic and finally the red eye with the oscillating
reflection. While the eye is displayed, the green light no longer
flashes and a white light flashes once instead. Then the backlights
behind the buttons illuminate. Eventually the oscillating reflection on
the eye starts to slow, the backlights behind the button go off and the
screen goes black. Then the green light starts flashing again.<br>
<br>I tried removing the battery but just got the same result. I plugged
the charger into the wall and got a 40% charge reading and waited for
it to go back to 100%. Then I unplugged the charger and tried powering on again with
the same result except that the green light stopped flashing for about
10 minutes. I put the phone aside for about two hours and came back to
try again with the same result, except that I plugged it into the
charger again and the battery was drained down to 30% despite the fact
that it had been at 100% two hours before and had not been used. I saw
recommendations in many threads to wipe the tried holding down the power
button and the volume keys simultaneously but nothing happened. I also
tried the camera button with the power button and the home button with
the charge button but no luck.<br>
<br>Can you please suggest what I might do to remedy the problem? Thanks!<br>&nbsp;<br>

02-07-2013, 05:24 PM
Let's see if you can get into stock recovery. From powered off, press and hold Home then Power. You must press Home first. Hold them both past the red eye til you get a screen with Andy the Android and a triangle with an exclamation point in it. At that screen press both volume keys simultaneously. That should open up the stock recovery. From there you can try a cache wipe.

Sent from my DROIDX using Tapatalk 2

02-07-2013, 05:38 PM
Thanks. I was able to perform the cache wipe. I then tried rebooting from the menu but, unfortunately, it went through the same routine of getting to the red eye and having the reflection slow down and then shutting off.

02-09-2013, 10:20 AM
Is the phone rooted or modified in any way?

Sent from my 4.2 jelly-beaned SCH-I535