PDA

View Full Version : Flickering and Banding on Droid X...Must heat up phone to see screen...



quadaunt
08-15-2012, 02:38 PM
This is a replacement / refurbished phone supplied by Verizon when my new phone, under warranty, would not turn on. This replacement phone worked fine for a month or so. After charging it one day I noticed that the screen was flickering and later that a gray, then black, band moved up the screen, completely obliterating all apps, text, etc. This phone is in a heavy duty case and hasn't been dropped, etc. Just by chance I found that when the phone was at room temperature the flickering and banding persists. However, when the screen is heated up, whether it be just being outside on a hot day, placing it in front of a heater vent in the car, hair dryer, etc., the flickering and banding stops. This only lasts aslong as the screen is heated up, though. Once it cools down it's back to the ol' flickering and banding.

I did some online research and found a number of entries from early 2010 that state that the flickering and banding was a "known issue" by Motorola and Verizon when this phone was launched (they say it was less than 1% of phones shipped...not sure that's accurate). According to the online posts Verizon asked customers with the flickering and banding issue to return their defective phones for brand new phones. I'm wondering if my more recent replacement / refurbished phone could actually be one of the defective phones sold in 2010. Motorola or Verizon might have thought they had fixed the phone and sent it out as my replacement.

Has anyone heard of this problem with the flickering and banding, with the only easy fix being to heat up the screen? I'm up for renewal in November, but Verizon said, since I'm a
16-year customer, that they would be willing to allow me to renew now. Unfortunately, this was the one renewal that I was going to put off as long as possible as I'm pretty ticked about there being no more unlimited data plan.

Thanks.

Goose306
08-15-2012, 03:37 PM
I never had that issue with my DX and it was a launch DX; however I have seen lots of posts about it. I never read into it much, but I believe it can be fixed yourself (taking it apart) I believe there is an issue with the screen or digitizer that causes the banding. Someone else who has had the issue may be able to pipe up a bit more of an opinion on it though.

quadaunt
08-16-2012, 11:00 AM
Thanks for the reply, Goose. Will keep fingers crossed that someone knows for a fix for this issue.

RickA.
09-09-2012, 04:23 PM
I had a similar problem and Verizon replaced that phone with a different unit, no questions asked, when I demonstrated the problem. for me, the top 15% was legible, the rest of the screen wasn't -- it looked like 'snow' on a color TV

Good luck