PDA

View Full Version : System UID Inconsistency Errors and Resets not working



wisequack
07-13-2012, 07:31 AM
My phone constantly gives me Force Close errors that eventually lead to an auto-reboot (sometimes in an infinite loop). Sometimes the errors are also System UID Inconsistency Errors. When I try to factory reset my phone, from within the OS or recovery, it doesn't work. Flashing an SBF has no effect either. Every time, when I reboot the phone, it is back to the way it was (functional but unstable). It seems like the phone doesn't have a long-term memory almost. Any ideas? Sorry for the dorky bolding, I may be doing something wrong but it seems like the formatting on this post is really lousy (I can't make paragraphs, wtf) and I don't like walls of text. More info to come for those with piqued interest.

wisequack
07-13-2012, 07:49 AM
My phone is an unrooted Droid X, out of manufacturer's warranty. It's on 4.5.621 from the OTA update from Verizon. The System UID Inconsistency thing is only every now and then, usually it's just Force Closes from failed programs. Sometimes when it auto-reboots it seems like it remembers the Factory Reset, because it comes to a "Welcome to Droid X! Click the android to continue" screen, but I have lots of Force Closes and UID Inconsistency errors and can't click the stupid android, just out of reach. Can't do anything but battery pull then. I've tried Factory Resetting from within the OS and through recovery. Within the OS just takes me to recovery. In recovery (hardware or after OS), the phone says data and cache are wiped, but when I reboot it's just like before. Seems to be rebooting to a set time in the past, because the time often changes dramatically as it loads up and gets the current time. For a while at the beginning it seemed to be restoring to July 4th, judging from the GPS location it thought I was in. I've tried flashing the SBF once Verizon said they couldn't help me. Flashed through a USB Linux boot first, then with RSD Lite. Never works, I get checksum errors in RSD Lite at the end. If I'm interpreting right, it looks like it may not have actually been able to write to the phone. I've heard rumors I need root to flash SBFs though, which would explain that. Despite the falures, I reboot to the system as before every time. One time I even corrupted the bootloader, which was scary, but a battery pull and power on later, the phone loaded as before, and double-checking the bootloader it was fine again. Crazy... Most of the info relevant to this issue I've documented here (http://www.droidforums.net/forum/droid-x-tech-support/216192-droid-x-uid-errors-unable-reset.html) although I've pretty much gone over it again in this thread as well. I'm willing to root my phone at this point, so if anyone has any ideas, no matter how crazy, please let me know. Preferably would like to try things starting from least risky and working up the risk ladder, but yeah. Wanna learn some too. Any advice appreciated!

wisequack
07-13-2012, 12:50 PM
Just stopped in Verizon's store and after an hour of them trying basic fixes I had already tried, they decided they couldn't help me. I'm already ready to root, just don't know where to start. Is rooting even possible with a phone that won't take a factory reset? Anyone? Anyone? :p

jeems
07-13-2012, 01:16 PM
Which type of SBF did you try? since you are on .621 you can only use the .621 sbf and there is only one way you can get root. See this thread for info about .621 and rooting: http://www.droidxforums.com/forum/droid-x-general-discussion/45783-important-info-621-update.html.

For now that's what I would try. follow this method to gain root and then maybe even try flashing a rom.

wisequack
07-14-2012, 11:22 AM
I originally used the wrong SBF, but caught onto the .621 thing and had been trying that since. Tried flashing it from Linux and Windows. Just tried the .604 Milestone X SBF, but no luck. Tried it through Linux, and got the following errors:
Checksum errors: CG31, CG33, CG35
"usb_bulk_read -110" error: CG39, CG42, CG47, CG61, CG64, CG65, CG66

Rebooting the phone brings me back to the normal screen (and I can still call out, as long as phone doesn't reboot). When it reboots itself, I still get "Welcome to DROIDX; Touch the android to begin." Looking at it right now. But System UID Inconsistency Error makes me unable to touch the android. That's the confusing part, seems like the phone doesn't remember its own changes, except for that screen. Maybe it has a backup that it's reverting to when the errors get too plentiful, not sure.

So yeah, I don't think I can get the SBF to flash permanently... any ideas on that aspect?