PDA

View Full Version : Problem rooting .621



scuzzo
06-20-2012, 06:13 PM
Had to sbf back to .621 then used the linux method to root my phone when everything went south. I've rooted before and had no problem This time I think I bricked it. Now when I use RSD lite to sbf .621 I get this error
Failed flashing process. Phone [0000]: Error getting subscriber unit information. Device API Error: 0xE00300007 Command: RQHW (0xE 0831007); phone disconnected.

newmanx4
06-20-2012, 08:21 PM
You just about can't brick an X. Does RSD recognize that the phone is plugged to the computer? Are you using your stock data cable or a different one?

Sent from my AOKP'd DROID X

Goose306
06-20-2012, 08:26 PM
I second Newman's opinion. After my adventures a few months ago trying to flash unsigned bootloaders and cdt tables, I've come to the conclusion that unless the hardware broke you can't brick it.

I would check USB cable and make sure its factory and also make sure its on a USB direct on the motherboard. RSD can be very finicky. Just curious, is there a reason you are flashing the .621 rather than .604? I mean if you are a rooter (which most anyone performing an SBF is) the .621 SBF is useless except unless you somehow botched the radio firmware or your returning it to sstock for insurance.

Sent from my Wiz Wiz MIUI!

scuzzo
06-21-2012, 03:36 AM
I bought the phone used and took the OTA .621 update. It is my understanding that all I can sbf to is .621. As for the factory data cable I have no idea where it is at. I'll try ordering another and see if I can get it going.