View Full Version : DX Stuck Before SBF Flash and acting the same after

05-21-2012, 10:17 PM
I searched and tried many different things for about 6 hours today to no avail any help would be greatly appreciated!

Version: .621 non rooted (yes I know there has been some problems with this new update, but this is what he has)
Battery when started: 75%
Coworkers DX has been very flaky lately so I said I would look at it. Plan was to clear cache and just do some cleanup and "start fresh"
Rebooted into Recovery. Hit the search key and it didn't do anything. So pulled battery and put it back in.
Then just trying to boot like normal and not into recovery it just stuck at the "M" screen.
Later found that with GB it is now the two Volume keys rather than the search key to bring up the menu in recovery.

So it wouldn't boot into OS, finally able to wipe cache and factory reset. Reboot and still stuck at M screen.
Used RSD and .621 SBF from Goose306 here : IMPORTANT Information Regarding .621 System Update! - Droid X - RootzWiki (http://rootzwiki.com/topic/19318-important-information-regarding-621-system-update/)
Loaded bootloader, recognized phone in RSD. Ran it. Went through whole process. Then it said it was restarting phone, I let it. Still sitting at M screen. RSD said to manually restart phone. Tried, but it won't turn off without a battery pull. Pulled battery, back to M screen.
So that didn't work.
Then I tried 1KDS's solution from here: http://www.droidxforums.com/forum/droid-x-sbf/23638-linux-solution-your-windows-rsd-lite-problems.html
Using this ISO: Milestone X 4.5.604 Gingerbread
Burned to CD. Ran it, followed directions. It went through everything fine till it said to let phone boot and skip activation, and some more stufff. Problem is I am still stuck at the "M" screen and didn't make it to the OS.

Then I had a Corrupt Data window because of Low Battery. Well I went ahead and spliced some power from a USB cord to override that and tried it again. Still to no avail.
Battery won't charge because there is no OS on the phone I assume. In the recovery menu the volume keys do not work properly to navigate. I can't go up at all, and only down if I hit them both simultaneously (which closes the dialog but moves the selection 1 space each time, don't ask me why:mad: I wanted to go back to .604 then run some roms and root, but I will take ANYTHING right now!

What have I missed? Any thoughts, direction? Is this thing finished?

05-22-2012, 07:39 AM
Morning bump as I try to get a functional DX back to my coworker lol
Sent from Windows Phone using Board Express