View Full Version : How do I successfully update to 1.3.418?

05-15-2012, 10:22 AM
I need to know how to update to 1.3.418. I am rooted on my DX2, and am very experienced with SBF / root procedures etc. I need a walk-through with links on how to update. I keep getting this update screen pop-up every two hours, and I want it gone. I also want to try a custom ROM for the first time. No experience at this. I am thinking eclipse? But if so, I need to know if my phone will be on 2.3.5 after the update or not.

05-15-2012, 03:57 PM
start here
Official 2.3.5 Root Method for Droid X2 1.3.418 OTA update

Sent from my DROID X2 using Droid X Forums

05-16-2012, 09:29 AM
Great! Thanks sd_shadow. New question. I was on an extended network yesterday at work and could not pull the OTA update, so I downloaded it from Al Gore's interwebs and loaded the zip file from the sdcard downloads folder, from boot, through clockwork recovery. However, it did not load correctly. It gave me some kind of corrupted load process failure TPS report. Everything stayed the same, except now when I try to pull the OTA update, the screen FC's and returns to the settings menu. It won't push the update either, I waited all night last night. My question is where should I place the file that I downloaded, what should I name it, and how should I load it to get it to load fully and correctly?

05-16-2012, 12:24 PM
I always install update with android recovery, not clockwork (BSR)
if that doesn't work you could, redownload or compare md5 checksum android md5 (https://play.google.com/store/apps/details?id=com.fab.md5&feature=search_result)/ windows md5 (http://download.cnet.com/md5-checker/3000-2092_4-10410639.html)
if you are using voodoo you should temp unroot (keeps backup)
make sure update is place in root of sd card (not in a folder)
rename it update.zip

05-17-2012, 11:50 AM
I'm not sure I know of android recovery. Is it an app? I don't think I have the right file. I moved it to the sd card root folder, renamed it update.zip and it gave me an installation aborted message. "Installing update... Verifying current system... assert failed:apply_patch_check("/system/app/ArcVideoEditorLite.apk", "37b52e0cb0099b869c3615329ec7e65a8739c44d", "47476da7d25ed1cdc5cc90d6451e13b6af391ac2:) E:Error in /emmc/update.zip (Status 7) Installation aborted." Does anyone have the correct update patch for 1.3.418?

05-17-2012, 12:34 PM
failed:apply_patch_check("/system/app/ArcVideoEditorLite.apklooks like you are missing a stock file how did you root, zurgrush can alter stock files, if so you need to sbf to 2.3.4 and root with Pete’s Root Tools (http://www.psouza4.com/Droid3/)

I'm not sure I know of android recovery just the name of stock recovery (http://www.droidxforums.com/forum/droid-x2-support/41785-common-x2-questions-answers.html)
update 2.3.5/1.3.418

47476da7d25ed1cdc5cc90d6451e13b6af391ac2 found same error here (http://forum.xda-developers.com/showthread.php?t=1192795&page=12) you need to SBF http://www.droidxforums.com/forum/droid-x2-support/37159-guide-how-sbf-x2.html

05-17-2012, 02:03 PM
Man. I removed so much stuff with Titanium Backup when I got this thing. I bet that was one of the programs. I'm flashing back to stock VRZ_MB870_4.5.1A-DTN-150-30_1FF_01.sbf, and then I'll see if I can't get this done the right way. I had originally tried to remove all the bloat and blur services myself, but I think this custom ROM thing is going to work out a lot better. Very informative sd_shadow. Many thanks.

05-17-2012, 03:21 PM
Got it! Onward to Eclipse!

05-17-2012, 05:00 PM
I can't flash Eclipse. Should I rename this update.zip and install from Android Recovery, or is there some other process?

05-17-2012, 08:05 PM
remove voodoo su backup
use clockwork recovery, install zip, install zip from sd card

edit: just follow direction here http://www.droidxforums.com/forum/droid-x2-roms/46031-rom-eclipse-v2-2-5-7-12-a.html

05-18-2012, 09:33 AM
Got it now! I was trying to install from Android Recovery, so it was giving me a signature verification failed error. Ran clockwork. Eclipse is buttery smooth! Thanks again!