PDA

View Full Version : Tried to Update MIUI, Rebooted Phone before installing, had to SBF, now can't root



EOppie
04-30-2012, 05:31 PM
I have a Droid X

System Version: 4.5.621.MB810.Verizon.en.US
Android Version: 2.3.4
Build Number: 4.5.1_57_DX8-51

I had MIUI installed, and was loving it. I wanted to update the phone to the new version of MIUI, and after wiping data I rebooted the phone prior to installing the update. This put the phone into a bootloop, and couldn't be broken with a battery pull. I SBF'ed the phone using RSD lite, and got it working again.

I went to root the phone using Pete's Motorola Root tools, no dice. It gives me an error on the last step.

When reading into this a bit, I see that I may have an issue since the phone was rooted prior. I did check via the abd shell command, and it does return a #, which I believe means it should work.

I have retried this a few times, rebooted the phone, rebooted the computer. For giggles, I also tried the variant for Mac OS and ran the script through the terminal. It came back with the error "cannot create /data/local.prop: permission denied, and finally with ERROR: root was not obtained.

Any help to get this back rooted so I can reinstall MIUI?

Thanks!

-Eric

jeems
05-01-2012, 09:58 AM
Looks like you SBFed to .621 so unfortunately you can't root with the one step method. Fortunately all is not lost. See this lovely post Goose306 posted for all info and links: http://www.droidxforums.com/forum/droid-x-general-discussion/45783-important-info-621-update.html

EOppie
05-01-2012, 10:05 AM
Well, I got it to work, somewhat.

I was able to flash and root my .621 using the guide to flash to Milestone
http://www.droidxforums.com/forum/droid-x-hacks/45037-noob-friendly-verizon-root-cm7-rom-guide-droid-x-621-ota-update.html

I then installed MIUI 2012.4.5 and restored my backup. I noticed that then I would be able to boot to the regular interface, let it run for about 20 seconds, and then the phone would reboot. I wiped /system /data /cache and dalvik cache, and reinstalled 2012.4.5 I began to manually configure the phone again, but noticed wifi would not work, and then the phone went into its boot cycle again.

I wiped again, installed MIUI 2012.2.1, and manually began to configure the phone. All seems to be working okay so far. Kinda curious to see what I am missing from MIUI 2012.4.5....

Still looking at trying to get Wifi tether to work, however it seems I may be lost being on Verizon.

EOppie
05-01-2012, 10:06 AM
you posted while I was posting! :-) Thanks for the update. Still have a few issues, but at least I am back up and running a bit.

jeems
05-01-2012, 10:11 AM
haha, ninja'd in your own thread!

If you feel the urge to try 4.5 again, there is a wifi fix in bootmenu. After you flash the rom and it boots up ok, reboot into bootmenu (via power menu or press vol down at the blue led during boot). Not sure if it will fix your particular issue but it's worth a shot. I know wiz is working on a pretty substantial revision, too, so keep an eye out for that.

EOppie
05-01-2012, 10:17 AM
Awesome, maybe I will just sit and wait then. I didn't know if there was any issue with it being installed after SBFing via the Milestone direction.

jeems
05-01-2012, 10:26 AM
I'm not sure if it has to do with the 621 root or if it is just something that happens on certain phones or with certain installs. Wiz would be the one to answer that question. Glad you are up and running though!