PDA

View Full Version : x2/milestone root question



acid_rain74
02-23-2012, 02:12 AM
My x2 is running Android 2.3.6, and all root attempts fail. Is this because of the version? I have tried SuperOneClick, PetesMotorolaRootTools, and MotorolaOneClickRoot. Provider is Bluegrass Cellular.

Nemo aeternamn
02-23-2012, 02:18 AM
2.3.6?
i didn't think that had been released yet for the x2... i'd only head of a leak that was 2.3.5... and for that version... you'd need to try the zugrush method... give it a try... i'll grab ya a link

http://www.droidxforums.com/forum/droid-x2-support/41785-common-x2-questions-answers.html

acid_rain74
02-23-2012, 02:28 AM
Thank you for the quick reply! Yeah I was surprised as well at the 2.3.6, I was thinking it would be as easy as my old x2 was lol! I will give your link a try and get back to you with my results.

Sent from my Milestone X2 using Droid X Forums

acid_rain74
02-23-2012, 02:57 AM
Ok, I downloaded and ran zergrush, following all instructions, and still no root.
Sent from my Milestone X2 using Droid X Forums

acid_rain74
02-23-2012, 03:39 AM
I'm giving up for the night, its nap time

Sent from my Milestone X2 using Droid X Forums

Arsonik
03-21-2012, 03:21 AM
I don't think anyone has found the root exploit for 2.3.6 yet. My suggestion would be to sbf back to 2.3.5 or 2.3.4 depending on the instructions on whatever rom you want (if you want one at all).

But I've also never heard of Bluegrass so this may be a carrier specific incident? I would try an sbf though.

acid_rain74
04-30-2012, 02:39 AM
:big smile: I found the solution, I rooted 2.3.6 using this guide (http://forum.xda-developers.com/showthread.php?t=1405077). It has to be followed to the letter, but definitely works! This really should have been posted in the milestone section, mods please edit/move this as you see fit.