PDA

View Full Version : Stuck on boot animation forever after attempting restore of ROM



skyler544
01-30-2012, 11:55 PM
I've flashed several ROMs and have become familiar with the sbf/root/rom installation process for both 2.2 and 2.3. However, while I was able to install Simply Stunning for the Droid X (SSDX 2.0), I cannot restore the backup I created this morning from either of the ROMs I've tried so far. That is, I wanted to try Apex due to some mobile data/wifi issues I had with Simply Stunning but still wanted to be able to come back to SS and all my data in case I ultimately preferred SS. Therefore, I made a backup and then tried to restore the backup of stock gingerbread I keep for ROM flashing purposes. That failed, leaving me in need of sbf, which I easily performed. However, after finishing the sbf and rooting the phone, my backup of SS would not restore either. Each time I make the attempt, I'm stuck with an infinite (I left it on in my pocket for 3 hours at work) loop of the SS boot animation. Next, I attempted to solve the issue by doing the sbf/root process and then simply installing a fresh copy of SS from which to restore my backup. That did not work either.

The catch here is that I forgot to backup my apps with titanium backup before starting the flash procedure, meaning that now I can either find a solution for my problem and restore my backup or lose about a month's worth of changes to my applications since the last time I used titanium backup. any advice would be appreciated.

cory46
01-31-2012, 12:09 AM
Which apex version did you try to flash? Also which sbf file did you use? (What color is the Motorola logo when your booting)
If I remember correctly ssx 2.0 is based from the froyo kernel. If you used the gingerbread sbf (602) you cannot go back and restore things from froyo (2.3.340) same with apex. If it's gingerbread based apex you cannot restore it from froyo nor go from froyo to gingerbread in a single restore.

You can use the 2.3.340 sbf file and restore ssx.

Sent from my DROIDX using Tapatalk

Nemo aeternamn
01-31-2012, 12:46 AM
If I remember correctly ssx 2.x is based from the froyo kernel.
Sent from my DROIDX using Tapatalk

Hey Cory... 2.2 is ginger bread... 2.1 and 2.0 is froyo


We have nothing to fear but running out of beer

cory46
01-31-2012, 12:50 AM
There ya have it thanks nemo!
You were on 2.0 now we just gotta figure what apex or sbf you used

Sent from my DROIDX using Tapatalk

skyler544
01-31-2012, 08:43 AM
as you can see here: http://www.droidxforums.com/forum/chevyno1/38779-ssx-2-2-2-3-7-incl-1-battery-other-goodies.html#post463683 the version of Simply Stunning that I flashed is clearly on the gingerbread kernel. In order to flash the rom, I had to first use RSDLite to sbf to stock .602 and then used pete's motorola rooting tools to root. ApeX 2.0.0 RC4 installed smoothly last night, however, ApeX is not a 2nd init rom and after only a short period of time messing with it, I do like SS better. What is difficult for me to understand is that even from stock (rooted) gingerbread, my backup of SS will simply not restore properly. Is this more of a question for the rom developer than for any of you?

p.s. this is where I have been going to get roms to try: ***Official Droid X Theme & Rom List*** (updated 1/30/12) - Android Forums (http://androidforums.com/droid-x-all-things-root/402999-official-droid-x-theme-rom-list-updated-1-30-12-a.html)

cory46
01-31-2012, 09:13 AM
So you flashed 2.2, not 2.0 like you said above?

I've flashed several ROMs and have become familiar with the sbf/root/rom installation process for both 2.2 and 2.3. However, while I was able to install Simply Stunning for the Droid X (SSDX 2.0),



Sent from my DROIDX using Tapatalk

skyler544
01-31-2012, 11:50 AM
yes, sorry. I simply had the ROM version numbers mixed up in my head. The version of ApeX I wanted to flash is 2.0.0 RC4, and the version of SS I flashed (and the one I'm trying to restore to) is 2.2 built FOR the droid x. The ROM version numbers don't correspond to the android version, as I'm sure you already know.

skyler544
01-31-2012, 11:52 AM
by the way, and I know this isn't the correct thread to ask in, but do you have a recommendation for a fast 2nd init rom that will work on the droid x? I was thinking of trying Liquid gingerbread and miui this weekend

cory46
01-31-2012, 12:26 PM
as to why you cant restore from a rooted stock gingerbread to SSX I don't know. I can only throw out assumptions as to why. and a few of them being

A. different clockwork recoveries (green text-version in droid x/2 bootstrap- versus blue text used for us using 2nd init roms) and they use different scripting techniques
B: you made a backup of apex with droid x bootstrap and debugging was enabled. Use droid 2 bootstrap on any non 2nd init rom that is based on gingerbread
C: you changed the backup name and added spaces into it (which you may have not done like i said im just assuming which is never a good thing ;) )

as for 2nd init roms based on the gingerbread kernel

CyanogenMOD
Updated Info On RevNumbers CM4DX-GB(1% batt and FM Radio added) - RootzWiki (http://rootzwiki.com/topic/10191-updated-info-on-revnumbers-cm4dx-gb1-batt-and-fm-radio-added/)

MIUI
http://www.droidxforums.com/forum/miui/43378-rom-miui-2012-1-30-bootmenu-update-1-battery-no-charge-led.html

these are currently the most updated and up to date 2nd init versions available

skyler544
01-31-2012, 03:43 PM
As far as CWM goes, when on a 2nd init rom I occasionally use rom manager but mostly just use the reboot options provided when long pressing the power button. It never occurred to me to use droid 2 bootstrapper in a 2nd init rom. However, I DID use droid 2 bootstrapper with rooted stock gingerbread to make the backup I keep to avoid SBFing each time as well as for the actual installation of roms.

By the way, I have never seen blue text in clockworkmod, only in stock recovery, which as I'm sure you know is next to useless.

I found out the hard way not to add spaces in the name of one's backups, but deleting the spaces fixed my stock gingerbread backup at least, so I can't see that as being the source of the problem. Besides, the backups were named in the default manner both before and after the problem manifested itself.

As for apex, I don't have any backups of that because I didn't try it until after I found out my SS backup refused to restore properly, so I'm not sure what you mean about making a backup with debugging enabled. However, in order to root gingerbread I needed it enabled, so the stock backup was made with debugging on and that oone works fine.

Finally, after another attempt today, on a whim I used stock recovery to do a data wipe after flashing the backup (unsuccessfully) and ended up with the android setup screen. That promptly asked to force close, leaving me only with what seemed to be the lock screen and the superuser app. I got a text message I couldn't look at (it vibrated and I got the LED) and was asked to install a superuser update from the market. That failed, but when I finally gave up fiddling and turned it off, I was able to get to CWM and flash the GB backup without any trouble.

Sent from my DROIDX using Droid X Forums

Brad92
01-31-2012, 04:16 PM
by the way, and I know this isn't the correct thread to ask in, but do you have a recommendation for a fast 2nd init rom that will work on the droid x? I was thinking of trying Liquid gingerbread and miui this weekend

CM7 is the best IMO. Liquid is CM7 with tweaks but I always had more issues with Liquid.

MIUI is very clean and the most unique Android ROM I have tried. It reminds me of iOS but with way more customization

X

skyler544
02-01-2012, 03:18 PM
I
What I want most in a rom is for it to not have trouble with my phone's hardware. Both CM7 and SS had problems with the hardware. While I prefer 2nd init rims, if they cannot adequately utilize the hardware while providing me with a better user experience, i'm not certain that the user experience is actually better. Perhaps with another phone CM7 would be the way to go, but as it is I like my camera and my GPS.

Sent from my DROIDX using Droid X Forums

cory46
02-01-2012, 03:19 PM
Camera and GPS work on cm7

Sent from my DROIDX using Tapatalk

skyler544
02-01-2012, 04:51 PM
Perhaps I'm mistaken, but unless I was secretly brainwashed into imagining 3 months of use of my phone with CM7 installed and without any camera or GPS functionality, I believe I must have flashed some kind of wrong version or something. If you would be so kind as to provide a link or verify this one: Download: CM7 Released for the DROIDX – Droid Life (http://www.droid-life.com/2011/06/15/download-cm7-released-for-the-droidx/) , I'll give the rom another try. I recall no issues other than those two, so I would actually be very excited to be able to use CM7 with that hardware working. However, I'm still lost on the whole restoring my backup thing. Here are some more details that I hope will help with the diagnosis: I installed SS over an installation of CM7. Following the data/cache/dalvik cache wipe procedure and then installing the rom was a success. The installation of SS seemed to perhaps not be quite right though, as it was very laggy in some areas. Music playback skipped when turning off the screen. I'm not sure if the rom is simply too complicated for the droidx to run smoothly or if I was doomed from the start, but neither option changes the fact that I'm frustrated by the loss of application data.

cory46
02-01-2012, 04:58 PM
The GPS and camera issues were fixed last July. GPS fixed in a nightly, camera fixed in a flashable zip. It's all self contained now and on gingerbread kernel here http://rootzwiki.com/topic/10191-updated-info-on-revnumbers-cm4dx-gb1-battery-no-charge-led-fm-radio-charge-while-off/

Sent from my DROIDX using Tapatalk