PDA

View Full Version : Battery will not charge, no LED light when plugged in.



Honnie
01-20-2012, 11:44 PM
Ok so I bought my droid x off ebay, from a trusted seller. The only problem was a bad esn but that didn't matter because I planned on using it on metro anyways. I received the phone early and all, but it will NOT charge. I tried four different chargers, i let it sit on two different chargers for two hours but nothing. I though the battery was just really drained and needed some time to charge, but I don't think that's the case. I searched around and found out that a LED light is supposed to come up once the charger is plugged..but I don't even get that. The guy said it worked when he charged it because he has a picture of the phone powered up and all.. Help anyone? Im going to try and let it sit for the whole day and see if any luck.

gunner1982
01-21-2012, 12:25 AM
If it is stock not rooted then no you won't get a led when charging sounds like theres, a problem because when you plug it in from a powered off state it will act like it's booting up but after the red m logo it should show a large battery icon and say that it's charging

Sent from my DROIDX using Droid X Forums

Honnie
01-21-2012, 03:42 AM
I'm pretty sure it was stock. I let is sit again for 3 hours this time and still nothing. No green led comes on either:cry:

gunner1982
01-21-2012, 09:49 AM
You might wanna check out the rescue squad section here you may find someone else who has or is having the same problem and you might be able to find a solution but it's hard to tell what's wrong if it won't charge

Sent from my DROIDX using Droid X Forums

BHuber09
01-21-2012, 09:54 AM
If it wont charge and you've tried numerous USB cables then you've got a bad charging port and I would suggest sending it in. However since there's a bad esn you should send it back to the Guy.
Or you could go to some rinky Dink place that can fix it.
Oh yeah and you won't get a led light. When its charging.

FreeMyMoto!!!

Honnie
01-21-2012, 01:21 PM
Alright guys so i looked around and read up somewhere keep re plugging and unplugging, whenever i do that i get the faintest flash of light from the LED.