PDA

View Full Version : No wifi....I know, I know....PLEASE HELP!



pizza_pablo
01-14-2012, 06:49 PM
My DX is stock with GB 2.3.3. my router is Linksys WRT54GL. Two laptops and an iPhone can access wireless internet.I can no longer surf, from home. I could a few days ago.I turn on WIFI, DX finds my network and states connected. Icon changes blue. No surfing allowed. All browser pages go to dead page in stock browser and Skyfire. Online Aps do not function.I was able to connect to free wifi at Staples store. The browser successfully loaded a page, even with white WIFI icon.I have tried manipulating router settings one at a time and sometimes rebooting modem and router after settings changes.I have tried procedures, listed below and others, as well, with no luck:"cleared cache on both browsers""Here is how to wipe the system cache on the Droid X (http://cellphoneforums.net/phone-database/Motorola_Droid_X.html). You should only do this is you are having issues with your phone (http://cellphoneforums.net/#). Make sure you back up your data before doing this!

Power the phone off
Power On while holding down the Home key
When exclamation point icon appears press BOTH volume keys
Use volume keys to navigate to "wipe cache partition" and tap the power button to select
Wait for it to finish and select reboot system"
"Try setting your router to G only. Then turn OFF any security. Also make sure your SSID is NOT hidden. Once you've done that, unplug the router's power. Then unplug your cable modem's power. Wait about 30 seconds and then plug in the modem and wait for it to boot up. Then, once it's up and running, plug in the router's power and wait for it to completely boot up.If you don't have it, I recommend grabbing Wifi Analyzer from the Market and installing it.Then, turn on your phone's wifi, go into the Wireless settings and "forget" any networks (http://www.droidforums.net/forum/#) you may have previously set up. Then, when they are all blank, go into Wifi Analyzer and see if it even sees your router's wireless (it should show the SSID, signal strength, etc.) If so, go back into the wireless settings and try to connect to your network. It SHOULD work now.Assuming you DID connect, go into your router and change to N-only (2.4Ghz since that's what the phone uses, not 5Ghz), don't hide the SSID, and turn off security. Note - I recommend naming the G radio something like AirportloungeG and the N radio AirportloungeN so you can distinguish between them. If your router is simultaneous dual band, I still recommend trying the two radios separately and one at a time before enabling both at the same time.At this point, you should also see the N network and be able to connect."also this, but found nothing of assistance:"Open up your dialer type *#*#4636#*#*See what it says about your radio and connection if the radio is on." Please reply if there is something else to try.

insanitylivz
01-14-2012, 08:20 PM
Sounds like you may be having an IP address conflict which is preventing your phone from accessing the router. If your phone is requeswting a particuliar ip address that has been assigned to another phone or computer it could cause this issue. Try disconnecting all the other computers, xbox, ps3, phone, etc from the router and unplugging the router for 15 seconds. Power it on and let it boot then before you connect any of the other devices see if your phone will connect. You may be able to change the time it takes your router to "release" the ip addresses in the configuration.

pizza_pablo
01-15-2012, 08:10 PM
Thanks, insanitylivz, but it didn't work.This is really frustrating!I realize that it is probably something that I did, but what that is, I cannot find

inuyasha.rules
01-23-2012, 05:35 AM
Do you have any non stock tethering programs installed? Mine sets local ips to 10.x.x.x which is what most companies use. All home routers use a 192.x.x.x by default, so if your phones looking for a 10 class it wont connect. Also go to settings > wireless and network settings > wifi settings > then the hard button on far left > advanced and make sure it has a check by auto ip. Also id try updating your routers firmware.

pizza_pablo
01-24-2012, 03:03 PM
Do you have any non stock tethering programs installed? Mine sets local ips to 10.x.x.x which is what most companies use. All home routers use a 192.x.x.x by default, so if your phones looking for a 10 class it wont connect. Also go to settings > wireless and network settings > wifi settings > then the hard button on far left > advanced and make sure it has a check by auto ip. Also id try updating your routers firmware.

No such programs / apps, but thanks for the thought.
It recently was able to connect AND surf, my home internet, but just once, briefly, in MANY tries \_0_/