PDA

View Full Version : updated Market app now crashing on launch.



bobthebob
11-24-2011, 08:16 PM
hey all - DX running Liberty 1.5 in Froyo 2.2.1 - I recently decided to upgrade my Market app to the latest version in order to get all the new functionality.

I upgraded to 3.3.1 using the ROM Toolbox app to first backup and then delete the Market app I had. then I just installed 3.3.1 and tried to launch it. it asked me for permission to access the net and then immediately FC'd on me.

so then I tried to restore to my backup... but it wasn't there! ahhh! no idea why... operator error I'm sure.

Anyway, here's a list of what I've tried so far:
- Manage Market App 'Erase Cache'
- Manage Market App 'Erase Data'
- Install and then restart
- Installing earlier versions including v3, v3.1.5, and v2.2.1 (2.2.1 actually made it to the startup screen before FC'ing the first time but not after that)
- Various combinations of all of the above.

now - I have no running Market app and can't seem to figure out what to do...

need some advice.

BHuber09
11-24-2011, 08:19 PM
Reflash the rom you are on. But then you'll have to refreeze the other bloat apps it comes with.

FreeMyMoto!!!

bobthebob
11-25-2011, 12:19 AM
"bloatware"? I'm running Liberty... not too much bloat on that ROM.

anyway - re-flashing my ROM is *VERY* much a last resort.

I've got a lot of time and effort into customizing my phone just the way I like it.

would rather find a way to FIX this problem!

thanks for the advice tho.

cory46
11-25-2011, 01:04 AM
Clear your cache either with a cache cleaner app you have installed or through clockwork (may help to clear dalvik in clockwork too) Install a market version and BEFORE opening the market clear the market cache and data then you should be able to open the market no problems


Edit: should add that your issues probably arose when you installed the new market. If you would have cleared market cache and data before installing it usually prevents all the fc's

Sent from my DROIDX using Droid X Forums

bobthebob
12-07-2011, 01:35 PM
thanks cory - I will try this.