PDA

View Full Version : 3.1.3 market isn't compatible with some apps on liberty .9



jfkabloozie
09-14-2011, 07:07 PM
Whenever I upgrade to 3.1.3, it sometimes works for a while, but eventually, usually after a single reboot, apps that i use like Facebook and Go Weather give me the message "Your device is not compatible with this item."

is there a fix for this?

tslovejoy1969
09-15-2011, 06:04 AM
This can happen if you've changed your LCD density to something other than 240.

Edit: Just to clarify, if you changed your LCD density, change it back to 240 and your market should be back to normal. Some people claim that they have to clear data and/or cache for the market app as well, but I've not had to do that. I haven't seen a fix for this yet, although for some reason the problem doesn't show up for me on the MIUI ROM, which makes me think there may be some way to fix it.

Sent from my Xoom using Droid X Forums

jfkabloozie
09-16-2011, 10:28 PM
That did it!

Thank you. I was beginning to get really frustrated.

Apparently liberty saved the lcd density settings on my sd and I flashed the rom a long time ago. when I went back to liberty, i thought it'd be default, but it wasn't.