PDA

View Full Version : SBF successful, but radio not working and dialer is missing



jazzbassist1
08-18-2011, 12:18 AM
I'll give you the whole backstory. Yesterday morning, I was running stock GB, unrooted, fully official in every way. I decided to put CyanogenMod7 on my phone. I used the Linux SBF kernel as described in this forum to get back to froyo

http://www.droidxforums.com/forum/droid-x-sbf/23638-linux-solution-your-windows-rsd-lite-problems.html (http://www.droidxforums.com/forum/droid-x-sbf/23638-linux-solution-your-windows-rsd-lite-problems.html)

Once I was up and running, I rooted with z4, ran ROM manager and droid 2 bootstrapper (the Cyanogen Wiki told me to use D2 and not DX bootstrapper), flashed Cyanogenmod 7 and the necessary radio fixes, and got it up and running well. Later in the evening, I tried to flash a small update, I cleared user data and the cache, but when I rebooted, I got stuck in bootloop. I tried clearing data/cache again, but it didn't work, so I said screw it, I'll just SBF again and start over.

This is where the problems come in. I SBF'd, and when I booted up into stock froyo, the cell radio would not connect to Verizon's network, and there are a few apps missing, notably the Dialer and just about anything associated with making phone calls. I managed to sideload the bootstrap and ROM manager, but ROM manager would not work properly even though I was connected to wifi. I've tried the SBF again and the same thing happened

So my issue is that I don't have any cell signal and or any way to install a ROM that would allow me to control the cell radio. Does anyone have any idea how to fix this? Any help would be greatly appreciated, I really hope I didn't brick this sucker.

cory46
08-18-2011, 12:21 AM
After the sbf did you enter stock recovery above wipe data/ factory reset?

Sent from my DROIDX using Droid X Forums

jazzbassist1
08-18-2011, 07:23 AM
Yes I went in to stock recovery and cleared the data/factory reset, and I also wiped the cache, and reformatted my SD card just for good measure (I have a backup of the SD card on my computer)

jazzbassist1
08-18-2011, 07:49 AM
Ok, so most of this work I did last night, and I woke up this morning and everything was still wrong, so I decided to give it one more go. With a nearly empty SD card, and data/cache wipe, I SBF'd, and it worked. Strange. Maybe I missed a step without realizing it.

I wanted to post my fix just for future reference in case someone else screws up their phone as much as I did :tongue: That's what this forum is all about!