View Full Version : Gmail not syncing

08-04-2011, 08:54 AM
Hi All
My gmail has been acting strangely. Its not refreshing and showing my new emails. When tapping on icon, it show 7 emails in my inbox but does not show them. When i click on labels it shows 7 in my inbox and says sync 7 days ago! My priority inbox which I dont use says sync all underneath it.
Clicking on all mail shows all my email thats not being listed in inbox. It seems my inbox is not being synced.
In settings - accounts, my sync gmail has a check box filled in!

Anyone have any ideas?
I have gmail on gb liberty .9

The persuader
08-04-2011, 09:52 AM
Mine is doing the same...

I Wiped data still happening

Its Bubba

08-06-2011, 07:36 PM
i've had this happen twice to me, and fixed it twice... but i don't remember how. You might have to uninstall updates to the gmail app, then reinstall them from the market... each time i fix it, ive done so many things i forget which one worked...

08-06-2011, 07:40 PM
Go to settings, accounts, and check auto sync

Loving me some Miui

08-07-2011, 07:28 AM
Go to settings, accounts, and check auto sync

Loving me some Miui
Thats not it. In Data and Sync , all my check boxes are checked so everything should be synced and in fact it is being synced. The problem is that the mail show up in "all mail" but does not go to "inbox"

08-07-2011, 08:12 AM
Also when I try to update in market to 2.3.5 I get a package is not signed correctly

08-07-2011, 08:22 AM
Months ago I had a problem with the native gmail app not showing mail.
Workaround: -I set up a regular email account on the phone, using my gmail login and password, and mae the account an IMAP account. For the next few weeks, the IMAP account worked fine, the gmail app... zilch. I opened a ticket with google, nothing. Then the gmail app just started working again. I ran both for awhile, just to make sure, but it hasn't happened since, so you can set up an IMAP account as a work around

08-07-2011, 08:11 PM
Can you explain in detail how to do it?

09-02-2011, 02:56 AM
Since updating my un-rooted droid x to GB a week or less ago, and besides the battery draining (which I seemed to have solved), and now my gmail.

First I noticed that I had new emails and it was marked as read. Now, I checked my gmail online, and saw 7 new emails, and I have been checking my email all day on the phone and never saw any new emails!

Help! Help! I am wishing I never updated my phone, if I could go back I would. I don't like the UI, anyway.

09-02-2011, 07:05 AM
Can you explain in detail how to do it?

Log into gmail on your PC, go to settings and click IMAP setup at the top. You need to enable it here first.
Directions are right there, but basically on the phone, create a new email account and put your google user and password in and it auto-configures

09-02-2011, 08:54 AM
I know with my Droid X, the new "priority inbox" was default selected after the last update. I had to change my settings to have my normal inbox syncing as usual

09-03-2011, 09:43 AM
I am still having the same problem. No new email s arrive in my inbox unless I reboot the phone. Then my new email show. It works fo a while but eventually the emails are only in my all mail folder.

09-04-2011, 06:25 PM
the only way i get new mail to inbox is to go to accounts and hit sync now. cant find where to make sync on all the time

09-05-2011, 09:23 AM
Try clearing your gmail cache in settings - apps -gmail.This seems to have worked for me

09-05-2011, 09:48 AM
Try clearing your gmail cache in settings - apps -gmail.This seems to have worked for me

I agree with above...I've run into this a few times before...and clearing the gmail data and cache worked.
Once cleared, your emails will not show up right away, it will tell you your emails will be available shortly. After the initial sync, make sure auto sync is enabled, and you should be good to go.
Then don't forget...any settings you did have will be gone (sig, confirms, actions....so on)