View Full Version : Blur Home woes... PULLING MY HAIR OUT!

08-02-2011, 09:20 AM
forgive me for the possible redundancy and or re-post, but nothing i've found thus far has worked, and every bug thread and/or support thread doesn't seem to consider this an issue. so, here's my question:

ok, so i've tried restoring the blurhome.apk in order to use it as my launcher, i've tried flashing the zip, i've tried running the chmod 755 command, i've tried tibu, and nothing works! I then tried to do a factory reset from CWM, wipe cache and dalvik, and then flash the zip via CWM. when the phone loads, i'm presented with the "setup" screen, once i go through that, it just loops me right back into the setup until it eventually force closes and then it just gives me a blank screen. i still have the notification panel, but no launcher.

i know it may seem like a silly thing to work so hard on, but i really prefer the blur launcher to any others (my personal preference).

any help would be amazing!

08-02-2011, 09:22 AM
If it's anything like Liberty, the blur home is problematic. Have you tried other launchers?

08-02-2011, 09:23 AM
When using the apk, are you placing in system/app & editing permissions... then reboot to see if it is there?

~~ sent from my x~~

08-02-2011, 09:32 AM
with liberty, all i had to do was flash the zip in cwm, boot up, go into root explorer, remove launcher2.apk, install "blurhome.apk" (just to make sure), and then press the home, and it works flawlessly. i've followed the same steps on apex, and nothing, just blank screen.


08-02-2011, 09:34 AM
and i have tried other launchers. i really do prefer the blur launcher for a couple of reasons. may be silly, but the 4 icons on the dock (cannot find any launcher that will do so easily), and the ability to resize widgets. if i could get launcher pro to have 4 icons across the dock, then i'd definitely jump over to lpp.

i've paid for lpp, but i just really want those 4 icons. haha

08-03-2011, 01:37 PM
anything? please?

08-03-2011, 01:43 PM
its not as easy to install blur files to apex because a lot of the blur framework and libs are removed comapred to liberty. you most likely have to add other blur elements to get blur launcher to work. if you are just going for the look of blur launcher pull the system blur icons and place them on your launcher of choice. other than the look 3rd party launchers offer more options than the stock gingerbread launcher does and the look can be replicated rather easy. here are a few skins I made that mimic the blur launcher look for launcher pro (plus included) all you need are the icons http://www.droidxforums.com/forum/droid-x-themes/27118-skins-launcher-pro-plus-skins.html

08-03-2011, 02:36 PM
actually got it! i take no credit for the following post/link over at rootzwikiGet back the Moto Blur home launcher on roms without it (not for CM4DX, MIUI, etc...) (http://rootzwiki.com/showthread.php?2369-Get-back-the-Moto-Blur-home-launcher-on-roms-without-it-(not-for-CM4DX-MIUI-etc...))

08-04-2011, 03:26 PM
Hmm still can't get it to work. I wasn't able to install BlurHome by opening it like they did in the link, so I copied the apk to System/app, set the permissions, and rebooted. Didn't work (as expected) so I rebooted in CWM and did Fix Permissions. However it still doesn't work. I'm not that interested in getting the Blur Launcher, but I have a feeling its the key to getting the Blur Media Dock to work, since I'm guessing its tied to the Blur Launcher.