PDA

View Full Version : Google Music Beta force close



stefan.gracik
07-13-2011, 10:23 AM
Google music beta force closes everytime I try to stream a song, it does fine playing music off the SD card. I have reinstalled, cleared app data, wiped cache, wiped dalvik cache, disabled scrobbling, disabled local caching of music, disabled ad blocker in Android Overclock, uninstalled Android Overclock, and still have had no luck. Does anyone know what could be the cause of this? I'm currently on nightly 25 but it wasn't working on 10 or 19 either.

zoe
07-13-2011, 11:17 AM
the only thing i know of was when i was on liberty, if the ad blocker was enabled I'd get the same issue you're experiencing.

I'm on nightly #27 and streaming works for me using adfree

only thing i can suggest...
something, anything else.. :)

stefan.gracik
07-14-2011, 08:49 AM
Hasn't worked on any nighties yet but I might as well give it a try... Thanks

Sent from my DROIDX using Droid X Forums

zoe
07-14-2011, 10:23 AM
silly question, but did you flash the gapps package? i flashed that once on the initial set up, and since I've only ever flashed the cam/camcorder/torch zip and the 1% batt zip. when going to a new nightly with only a dalvik wipe.

are you running any other audio streaming apps, i have mspot and that works fine as well. while not the same type, netflix also streams fine. i haven't made any significant changes to the rom, pretty much an oob box install w/ the 2 fixes tho i did update the radio to .12 but that's for the phone functions

at home i mostly use wifi but it works fine on 3g too.

i also have android overclock.

idk as what you describe is close to my setup (?), but mine works

something, anything else.. :)

stefan.gracik
07-14-2011, 12:22 PM
I flashed the gapps in the initial beta rom that's it, and now I have the cm4dx all in one fix. I've been doing dalvik and cache when flashing nightlies although I didn't wipe anything for the first few.

I have NPR News which streams well, otherwise I have Winamp and Last.fm but I haven't used either in awhile. Only changes I've really made were theming, I still have the .07 radio.

Streaming doesn't work for me on wifi or 3g. What is strange is that it used to work on CM7, I can't really be sure when it stopped working but I'd guess around nightly 10. In fact lots of things have gone to crap in the few days after i flashed nightly 10, for instance my USB mass storage mode doesn't work, my SD card won't even unmount actually. Also wifi randomly stops working and it's only fixed by flashing a backup made when Wifi was working.

When I list all these problems out, it makes me think I should probably factory reset and start over on Cyanogenmod.

edit: apparently my SD card does unmount now haha, I'll have to try USB mass storage when I get home from work.

zoe
07-14-2011, 04:44 PM
a nandroid before sbf and frsh install would get you back, but no wait, a nandroid would reintroduce the prob.

if your comfortable setting up the phone from other backups, then yeah a sbf may be a good idea

something, anything else.. :)

brandonfish
07-14-2011, 04:51 PM
I had the same problem on every nightly install. Just uninstall google music and download again from the market. It's always worked for me . . . (SORRY) didn't read your whole post. Make sure you don't have any other programs that have ad-blockers I know CM7 has a setting for it, and if you have something like root tools or masqed crusader, they could also be ad-blocking.

woodfielder
09-17-2011, 12:00 PM
ever get a solution to this?? im trying to diagnose my prob now. ive enabled adds via Rom Tool box (jrummy) im on cm7. still get fcs

stefan.gracik
09-18-2011, 12:39 AM
ever get a solution to this?? im trying to diagnose my prob now. ive enabled adds via Rom Tool box (jrummy) im on cm7. still get fcs

Ya, well I eventually got fed up and sbfed, then flashed MIUI and the music beta has worked ever since.

I don't really know for sure but I bet it has something to do with me using the monster.zip installer for cm7 instead of just sbfing to Froyo and then flashing cm7. Did you use the monster.zip file to get onto cm7?

woodfielder
09-19-2011, 03:03 AM
yes but it was working for months until i tried gb cm7 and went back to froyo cm7

thejamhole
09-19-2011, 10:30 PM
I was getting that all of the sudden one day, then randomly it started working again. Didn't really change anything that I can think of. I'm on justice .1. I figured it was something on google's end and they fixed it. I could play songs on my device fine, but streams were fc.

stefan.gracik
09-21-2011, 11:09 PM
Mine worked for awhile I think on cm7 and randomly stopped. I don't really have justification for it but I really think it had to do with the monster.zip install instead of sbf.

Maybe check ad blockers too...

Sent from my DROIDX using Droid X Forums