PDA

View Full Version : [HELP] ApeX 2.0 RC 2 - Stock Blur Messaging App



syphen
07-11-2011, 10:57 AM
Let me start by saying, I love this rom. Been running it solid for a while with no issues (that I can see). That being said, I am one of "those" people who kind of liked the stock blur messaging app that came with the DX. I have tried a bunch of different things and just can't seem to get it to work. For documentation sake, here is what I've done:
Downloaded the removedapps-596.zip (http://www.mediafire.com/?myr6vl14ohpccdc)
Installed Root Explorer (http://market.android.com/details?id=com.speedsoftware.rootexplorer) (and opened it)
Navigated to /system
Selected 'Mount R/W'
Copied the following files into the /system/apps directory: BlurEmail.apk, BlurEmailEngine.apk, Conversations.apk, Messaging.apk and UniversalInbox.apk (there were a few threads that pointed me to grabbing these)
Reset the permissions for these files to: Owner: Read, Write; Group: Read; Others: Read
Navigated back to /system
Selected 'Mount R/O'
Bootstrapped (Using Droid 2 Bootstrap)
Wiped Dalvik Cache
Reboot
Now when I open up the blur messaging app, the screen blinks and that's it. Does anyone have any suggestions?

Thanks,
Syphen

syphen
07-12-2011, 11:21 AM
Now I know I didn't stump everyone. Anybody?

syphen
07-14-2011, 11:08 PM
Bumpity.

Sent from my DROIDX using Droid X Forums

Droid-Xer
07-14-2011, 11:42 PM
Apex RC02 is aosp. So i dont think you can add any blur back since its blurless.

CURBSHOT
07-14-2011, 11:43 PM
For the record that is one of the parts I like in blur too. Can't believe no replies.

Sent from my DROIDapex 1.4 waiting for a more stable gb rom... ssx is cool

linuxtrance
07-15-2011, 12:13 AM
I added the camera back by freezing the aosp camera and then installing the blur camera, maybe you could try freezing the stock email app... also, you could try to set the permissions from terminal emulator. Check out post #3 in the Apex 2.0 release thread.

Sent from my DROIDX using Droid X Forums

syphen
07-15-2011, 09:02 AM
I thought I had set the permissions correctly. Should they be set to 755 instead?

linuxtrance
07-15-2011, 06:29 PM
That's what I set for the camera apk,user should be read, write, execute and others should be read and execute.

Sent from my DROIDX using Droid X Forums

Yeti 6
07-16-2011, 11:46 AM
Syphen. Give this a try. Copy the .blur apk's you want restored in the /system/app .zip file. Then go into bootstrap and reinstall the zip. I tried what you did with RC2 and it didn't work. When I installed my apk's to the zip /system/app, then installed the zip, all worked well. Good times.

syphen
07-18-2011, 08:40 AM
What file should I do this in?

Yeti 6
07-19-2011, 08:17 AM
Syphen. The rc2 rom file that you downloaded, don't unzip it. 1. Use a zip utility to open, not unzip, the rom .zip file. 2. Go into the system/app/ directory.3. Copy the blur files you want into the /app/ directory.4. Once you've copied the blur files you want, delete the AOSP files that blur is replacing. (ie. The old camera and e-mail files)5. Copy the rom to your phone and reinstall. You should be good*** Make sure you make a backup copy of the unmodified rom before doing this!!! ***Hope this helps.