PDA

View Full Version : Fixing your unique SSX issue



HarleyDude
07-06-2011, 11:39 AM
If you experience any issues with your SSX install that have not been reported, please continue to post your questions and results in the http://www.droidxforums.com/forum/chevyno1/31087-ssx-bug-thread.html.
For the most part, the following would be the steps I will recommend to troubleshoot and fix your issue. These steps go from the least disruptive to most disruptive.
Make sure you followed the install directions. Hopefully, you did a data wipe/factory reset and a dalvik cache wipe before the install. This has already been determined to be the cause of many issues.
Make a current nandroid and TiBu backup. Do it NOW!

Note: After running each step below, check to see if problem still exists

1. Reboot your phone (pull battery, power back on), always the first thing to try (almost no effort or time involved)
2. If it's with an individual app, uninstall and re-install the app and reboot the phone again
3. Boot into recovery>advanced>wipe Dalvik & cache (extra long boot time after this)
4. Remove any custom theme
5. Re-flash the SSX ROM (also fairly easy, with minor disruption)
6. Do a data wipe/factory reset (obviously disruptive)
7. Re-flash the SSX ROM
8. SBF back to Froyo
9. Reinstall SSX-you should now be golden

Post-flash
If you've done the data wipe or SBF, you now need to get your apps/data back, using one of 2 options (advanced restore or TiBu).
First, make a new current nandroid, if restoring apps/data screws something up, you won't have to start all over again.

Easy and quick restoration (has worked for some, including me, not so well for others, including STG)
Reboot into recovery, go to restore>advanced>restore data partition and use the nandroid you made before step one above. If the problem was in the system, this will work. if the problem was in the data partition, this will re-introduce the problem, so it's good you followed the instructions and made a new nandroid

The other option is to restore your apps and data with your current TiBu backup. Do it selectively, a dozen at a time, and verify your original issue is not re-introduced

Some of the one-off issues that have been seen and fixed
Themes not sticking on reboot (fixed by data wipe)
LED light settings grayed out and not working (fixed by SBF)
Bootanimation script not working (fixed by data wipe)
Wallpapers not setting
Couldn't turn on GPS (fixed reboot)

ChevyNo1
07-07-2011, 08:47 PM
HD - can I get mod privileges in my forum? Was going to sticky this and found out I couldn't ;)

HarleyDude
07-07-2011, 08:55 PM
That would be an admin question, I can sticky it for you

ChevyNo1
07-07-2011, 09:05 PM
Thanks man - who would I ask?

HarleyDude
07-07-2011, 09:07 PM
LOL, you already did, I'm sure STG, if not some of the other admins will see this post, but I'll pass on the word along

tmar23
07-13-2011, 03:32 PM
I read that this rom includes the sony launcher, but I cannot find it. It defaults to adw, I think. I do not see an option for it on home switcher? Is there a setting I am missing? For now, I am using go launcher.

Sent from my DROIDX using Droid X Forums

HarleyDude
07-13-2011, 03:34 PM
I read that this rom includes the sony launcher, but I cannot find it. It defaults to adw, I think. I do not see an option for it on home switcher? Is there a setting I am missing? For now, I am using go launcher.

Sent from my DROIDX using Droid X Forums

Interesting, mine defaulted to sony. Go into settings>applications>manage applications, find adw and clear defaults, do the same with go, then press home, it should give you the option of all installed home launchers, including sony

tmar23
07-13-2011, 03:53 PM
I did that, but no luck. It just lists adw and go when I select a home launcher. Wierd I also do not see it as an appc should it be listed as separate app?

Sent from my DROIDX using Droid X Forums

HarleyDude
07-13-2011, 04:26 PM
I did that, but no luck. It just lists adw and go when I select a home launcher. Wierd I also do not see it as an appc should it be listed as separate app?

Sent from my DROIDX using Droid X Forums

If it doesn't list sony, its cause its not installed. You can co to settings>applications>manage applications>all tab and see if sony launcher is listed, but it's probably not there, in which case I suggest following the steps starting with 4 in the OP to try to get it back, as something happened during your install

tmar23
07-13-2011, 09:02 PM
Ok, I will give that a try. Thanks for your help.

kochoid
07-13-2011, 09:47 PM
H.D., you're a cool cat. Thanks for helping the rest of use out. I've tried ssx three times and each time some issues arise that make it a deal breaker. Number one, my launcher pro transitions are occasionally choppy. cm4dx does the same--original and nightlies 7 and 25 (although 25 was considerably better). Another issue is choppy screen animations to apps and within apps. All this with no, low, and moderate overclocking. And lastely, 600+ songs are scanned and lumped in unknown artist. These songs are from iTunes and some from amazon and some from my own CDs and they all have complete and correct tags. cm4dx does this too. I'd love to run ssx, bit these things are just too annoying. Please, obi wan kanobe, help us. You're our only hope.


Sent from my DROIDX using Droid X Forums

Sean Wristen
07-14-2011, 10:02 AM
The issue I am having is I want to calibrate my battery. But when I let it drain and power off, and plug the wall charger in it revolts,will not stay off. Anyone have any ideas?

Sent from my DROIDX using Droid X Forums

HarleyDude
07-14-2011, 11:13 AM
H.D., you're a cool cat. Thanks for helping the rest of use out. I've tried ssx three times and each time some issues arise that make it a deal breaker. Number one, my launcher pro transitions are occasionally choppy. cm4dx does the same--original and nightlies 7 and 25 (although 25 was considerably better). Another issue is choppy screen animations to apps and within apps. All this with no, low, and moderate overclocking. And lastely, 600+ songs are scanned and lumped in unknown artist. These songs are from iTunes and some from amazon and some from my own CDs and they all have complete and correct tags. cm4dx does this too. I'd love to run ssx, bit these things are just too annoying. Please, obi wan kanobe, help us. You're our only hope.


Sent from my DROIDX using Droid X Forums

I've had zero problems with LP, same with screen transitions. I added this to the last line of my build prop to help LP.
ro.HOME_APP_ADJ=0
Make sure to hit enter after typing it in, you need a blank line below it.
I also did this from another post, the original change was to 60, I have mine at 75. I don't know if any of this will help, but it's something to try.
To enable better scrolling speed through lists, I changed
windowsmgr.max_events_per_sec=55
to
windowsmgr.max_events_per_sec=75

Can't help with the song problem, other than if you're in the philly area, or cloud based, I'm sure my kid will tag all your music for a fee LOL

HarleyDude
07-14-2011, 11:14 AM
The issue I am having is I want to calibrate my battery. But when I let it drain and power off, and plug the wall charger in it revolts,will not stay off. Anyone have any ideas?

Sent from my DROIDX using Droid X Forums
Plug it in first, then power off

Sean Wristen
07-14-2011, 11:24 AM
Plug it in first, then power off

Ok, but don't you have to drain the battery till it shuts down. Then charge to 100 % and then wipe stats?

Sent from my DROIDX using Droid X Forums

HarleyDude
07-14-2011, 11:35 AM
Ok, but don't you have to drain the battery till it shuts down. Then charge to 100 % and then wipe stats?

Sent from my DROIDX using Droid X Forums

I never drain my battery all the way down, more afraid of damaging the phone than a calibration routine being perfect. But if you want to follow that routine, it's actually wipe stats, then discharge and full charge. There are apps on the market that will do it for you, but if you want to do it manually, wipe stats, let it run down, then plug it in to a full charge, nothing says it needs to be off when recharging, just wipe stats, full discharge, then full recharge

Sean Wristen
07-14-2011, 11:40 AM
I never drain my battery all the way down, more afraid of damaging the phone than a calibration routine being perfect. But if you want to follow that routine, it's actually wipe stats, then discharge and full charge. There are apps on the market that will do it for you, but if you want to do it manually, wipe stats, let it run down, then plug it in to a full charge, nothing says it needs to be off when recharging, just wipe stats, full discharge, then full recharge

Ok thanks HD

Sent from my DROIDX using Droid X Forums

shagg9
07-22-2011, 09:25 PM
Help! My backup assistant will not load! Two reflashes w wipes and no sync! Grrr! So this may be the end of the line for this rom for me. Help me please. Otherwise its slick!

Sent from my SSX DROIDX using Droid X Forums

HarleyDude
07-23-2011, 06:48 PM
Help! My backup assistant will not load! Two reflashes w wipes and no sync! Grrr! So this may be the end of the line for this rom for me. Help me please. Otherwise its slick!

Sent from my SSX DROIDX using Droid X Forums

Sorry, I never used backup assistant, so I don't know if it works with SSX or not. I also don't know what it backs up, but there should be alternatives for whatever you want to back up

jwalz
08-17-2011, 08:06 AM
Getting force close whenever I try and open gmail app. Anyone else have the issue

hmmmmm what shall I flash today? I feel simply stunning. lets try that

HarleyDude
08-17-2011, 10:59 AM
Getting force close whenever I try and open gmail app. Anyone else have the issue

hmmmmm what shall I flash today? I feel simply stunning. lets try that

I think I did at one point, but it was awhile ago. First, from settings>applications>manage applications>all tab, gmail and clear data. Then try going to the market and re-install or upgrade the gmail app.

jwalz
08-18-2011, 08:16 AM
Thanks Harley for the reply. When I went into market I had an update for it.took the update and it works fine

hmmmmm what shall I flash today? I feel simply stunning. lets try that

HarleyDude
08-18-2011, 11:40 AM
Cool, I think that's what fixed mine too

jwalz
08-18-2011, 11:42 AM
Ok found another issue I'm having....video cam doesn't work...can does but when I switch to video the screen goes black and if I switch back to came it force closes

hmmmmm what shall I flash today? I feel simply stunning. lets try that

HarleyDude
08-18-2011, 11:45 AM
Did you flash the camcorder fix?
http://www.droidxforums.com/forum/chevyno1/31282-camcorder-fix.html
If yes, try flashing it again

jwalz
08-18-2011, 11:56 AM
Which did u do? There is a new one that includes the 1% battery fix...

hmmmmm what shall I flash today? I feel simply stunning. lets try that

HarleyDude
08-18-2011, 12:01 PM
Don't do the 1% battery, at least until you read this
http://www.droidxforums.com/forum/chevyno1/31840-1-battery-fix-ssx-workaround-use-ssx.html

jwalz
08-18-2011, 12:04 PM
Good stuff thanks alot for the heads up man. Greatly appreciated
Edit..works like a charm thanks again

hmmmmm what shall I flash today? I feel simply stunning. lets try that

HarleyDude
08-18-2011, 12:08 PM
No problem. There's some good stuff in the ChevyNo1 (http://www.droidxforums.com/forum/chevyno1/) sub-forum, look thru the tricks thread http://www.droidxforums.com/forum/chevyno1/31197-chevyno1-ssx-neat-tricks.html and some of the others

jwalz
08-18-2011, 12:09 PM
Ill have to.check it out

hmmmmm what shall I flash today? I feel simply stunning. lets try that

xjeepguy
09-30-2011, 12:48 PM
I am playing with this rom, and love it. but..... it will not go into landscaape mode. I have checked the settings, I have cleared data/cache/dalvic and as soon as I log into google, it goes into portrait and stays there. Even while texting, it stays in portrait. Any ideas?

hsuede
10-11-2011, 05:53 PM
Does anyone know a fix for the swipe status bar for brightness issue? Brightness notification widget doesn't work either. Thanks in advance!

Solomongrundy
02-14-2012, 10:16 AM
I have been running SSX 2.2 for a couple weeks now. Everything has been working fine, but one thing has just come up. I noticed that the launcher bar at the bottom of the screen, that has the 3 buttons, along with the dots on each side of it for each slide panel, disappears. A simple reboot of the phone bring it back up, but just kind of annoying. Anyone else see this issue before?