PDA

View Full Version : Droid X Car Mount Repair



mooler
06-23-2011, 10:34 PM
I have a Moto Droid X Car mount that I picked up a couple of months ago. It has been on my windshield for maybe the past 2 weeks. Today I went to turn the wingnut to adjust the height of the mount and It just cracked off. the knob is in pieces. It has been in the upper 80's and 90's lately so I assume heat had something to do with it. It can still be adjusted using the screw that holds it in place but that would be a pain. Is there anyway to repair it? I tried using a standard metal wingnut but it seems the screw becomes too short to lock into place. I would take it back to verizon but I lost the aux cable. What do you guys think?

Edit: Problem solved. I am using a cork washer for now. If I can find a thin enough wingnut I may just paint it black

19544

What do you guys think? and has this happened to anybody else

klickin2k
06-28-2011, 08:22 PM
I had the same exact thing happen to me. Got mine in December 2010 and it broke in April. I looked at the warranty, and it had a 1 year warranty, so I called them up. I told them what happened and they said it wasn't covered. I started complaining that I had only had it for 4 months and was just loosening it to adjust it when it broke, and they finally gave in. They said they would send me a replacment "just this one time". I got the replacment and they didn't want the old one back either. Came brand new in the box with all the original accessories. FYI...if the cradle part shifting on the two slots on the back irritate you, I just drilled 4 holes in each corner of the small square part that mounts to the "ball", attached that to the mount, lined it up, drilled the holes through the mount and screwed in 4 small screws (about 1/4" -3/8" long and about 1/8" diameter). Rock solid now. It I want to remove it i just unscrew the round "wing nut" thing and pop it off the ball. Hope this helps you or someone else.

70351
09-16-2011, 02:22 AM
Apparently these things have a problem with this issue because mine did it too. I have two of these and the one that broke was sitting new in the box for the past 3-to-4 months, and the very first time I took it out to use it the screw tab broke off just like everyone else's. I'm sure there must be more, they just haven't come here to report it.

The one that came with my DX seems to be okay and is the one is Use everyday in the car. However, the extra one I have sat in the box in the house for a few months and THAT'S the one that breaks. That tells me it wasn't the heat or any kind of use issue, but likely a manufacturing process such as weak plastics, etc. :mad2:

I thought about calling them about it but I'm sure they'll just give me a bunch of BS since it's been about 3, maybe 4 months since I bought it. On second thought maybe I will call them since they sent "klickin2k" another one :excited:

I'm curious though, my *good* mount came with my DX and was included in the same box when I bought it at Walmart in May 2011. The *bad* mount came in the online kit Verizon had on special for only $19.99 a few months back, which is how I ended up with a 2nd mount. The kit had the mount, HDMI cable, bedside stand and 3.5mm cable and maybe even one other thing . . . can't remember now.

Of those that broke, were any others from the "kit" like mine?

70351
12-03-2011, 08:50 PM
I guess this thread has died. No more answers from anyone . . . :starstruck: