PDA

View Full Version : Extended Battery Issue



ras0787
03-17-2011, 10:25 AM
I just got my new extended battery yesterday finally. When I plugged it in it immediately showed at 60%. I figured they came somewhat charged or something. Anyway I left it on the charger overnight, but when I woke up unplugged and tried to turn the phone on it wouldnt come on at all. I plugged it back in and it showed up at 60% again. I tried to turn it on while plugged in, and it came on for a second and shut itself right off. For a second I thought something was wrong with my phone so I put my normal battery back in and it worked as normal.

Is there a problem with the battery, or is it a problem with my phone? Has anyone experienced anything like this? It's a brand new battery I dont see why it wouldnt be working :sorry:

maybish
03-17-2011, 10:30 AM
Sounds like a problem with the battery. Call the company up and send it back for a replacement!

~~**May's X**~~

ras0787
03-17-2011, 10:53 AM
That sucks, I got it from verizon lol

John.Borgen
03-19-2011, 04:30 PM
Ugh, my Gorilla Gadgets battery arrives today...I hope I don't have any issues.

RubiX 2.0.1 | Mysterious Beast

TRook45
04-16-2011, 05:32 PM
I had the same problem with an extended battery from Gorilla Gadgets, sent the battery back they were going to send me another battery. After 2 weeks no battery, found out they forgot to ship it so told them to just give me a full refund. I think it is a issue with the phone not reading the new battery.

jkt
04-23-2011, 09:51 AM
I knew better, but I also went with aftermarket gorrila gadgets battery. I had the same problem. I sent it back and oredered one from Verizon. It works just fine. Also, even with the ext battery my otterbox defender case still fits. A nice surprise.

fersayken2
04-23-2011, 10:01 AM
I had a problem with one too. I kept pulling battery and plugging charger in all kinds of ways. I finally pulled the battery and left it out and then plugged charger in until the battery with a question mark came up. I put the battery in and it has worked ever since. It did this again when I was calibrating it and ran it until it died. I have since done the same calibration technique and it worked fine. So.......???????????????...lol

Sent from my DROIDX using Droid X Forums