PDA

View Full Version : Updated to 2.3.340 but it still wants to download the update OTA



jmetcalfe84
12-13-2010, 08:46 AM
Okay so i'm trying to figure out how to get rid of this stupid box that keeps popping up about 8 times a day "Download of update failed".

I actually got the OTA updated downloaded then it tried to install the update but it didn't work and just rebooted my phone. Since I was having a hard time updating OTA because I was deodexed and rooted I SBF'd back to 2.3.15. After that I did a manual update through the SD card with the update.zip that I got online. But ever since then it still keeps trying to update OTA or something. Does anybody know how to make this go away. Is there some cache I need to clear or something?

joshw0000
12-13-2010, 09:12 AM
Are you on a custom rom on 2.3.340? I don't think OTA's will come through if you are. OR maybe freeze or delete some stock apps. I haven't taken the OTA yet so I'm not sure it'll work but from what I've read you must be on a stock set up to get the OTA (I'm on a custom 2.3.15 rom and haven't got the notification). Good luck!

Sent from my DROIDX using Droid X Forum App

joeyjackpot
12-13-2010, 10:14 AM
There is a setting somewhere to not automatically download updates, though I can't remember where it is.

eric eakin
12-13-2010, 10:18 AM
There is a setting somewhere to not automatically download updates, though I can't remember where it is.
was it Settings/ Data Manger/ Data Delivery/ Social Applications/ Sync only over wifi?

joeyjackpot
12-13-2010, 10:43 AM
No, it's a setting that is specifically for the downloading of updates.

Cigator
12-13-2010, 11:03 AM
No, it's a setting that is specifically for the downloading of updates.

I think you can freeze the updater.apk or something like that to stop updates.

Wingnuts
12-13-2010, 11:41 AM
I followed davidx's suggestions on another thread to block the update.

Rename the following: BlurUpdater.apk and Upgrader.apk The notifications are gone, and you can't manually update through the menus either. Don't delete the files - just rename them!

I did this last yesterday and so far, it seems to be working.

joeyjackpot
12-13-2010, 12:01 PM
I followed davidx's suggestions on another thread to block the update.

Rename the following: BlurUpdater.apk and Upgrader.apk The notifications are gone, and you can't manually update through the menus either. Don't delete the files - just rename them!

I did this last yesterday and so far, it seems to be working.


maybe this is what i was thinking of - but i know there are definite ways to ONLY block updates without reducing other data sync

jmetcalfe84
12-14-2010, 03:23 PM
I think the problem is from me installing the update.zip from my SD card when it had already downloaded it from OTA and failed halfway through the install.

I think if I would have retried the OTA download after SBF it probably would have been ok.

Is there any way to go back and redo the SBF and let it update OTA, i've read I would have to SBF back to 2.3.320 since I cannot go back to 2.3.15?

joeyjackpot
12-14-2010, 03:34 PM
Why don't you just let it update to itself? It won't change your OS... and you'll stop getting messages

jmetcalfe84
12-15-2010, 09:29 AM
Why don't you just let it update to itself? It won't change your OS... and you'll stop getting messages

I tried that right off the bat but it won't. Everytime I go into settings and about phone, then I hit system update and it brings up a box saying

A update is currently being downloaded. You will be notified when the download is complete.

Then it never does anything, this is probably due to the OTA downloading before and then not installing correctly I think.

jmetcalfe84
12-15-2010, 10:13 AM
I think i'm going to try to SBF back to 2.3.320 then do the OTA update to get to 2.3.340 and hopefully that will fix the problem.