PDA

View Full Version : WHy Isn't Z4 Rooting My X after Update?



Cigator
12-12-2010, 07:55 AM
Worked fine before update. I unrooted before update, now trying to root again and it just spins. It took less than a minute before. How long should I let it spin before giving up?

CrAsH_OvErIdE
12-12-2010, 08:04 AM
Uninstal. And get a fresh copy.

Sent from my DROIDX using Droid X Forum App

Cigator
12-12-2010, 08:15 AM
Uninstal. And get a fresh copy.

Sent from my DROIDX using Droid X Forum App

Just tried that, no luck. I didnt do anything but update. Now no root.

Foxfire
12-12-2010, 10:23 AM
I'm Z4Rooted as well and have not allowed the up date for just this reason......many more knowledgeable peep's here than me, so I decided to wait for the smart ones to figure out all of the issues before I messed around with the up date. I'm grateful just to know how to turn the X on!! LOL

seanr42
12-12-2010, 11:55 AM
I had that problem also it was just spinning I just restarted the phone and hit root and it did it real quick. Might try that

SimplySweetness
12-12-2010, 11:56 AM
I have updated and rooted with Z4 with no problems at all.

Btango05
12-12-2010, 12:14 PM
Same boat here....well here's my situation maybe someone can help.

Was rooted via DoRoot method on OTA 2.2.... updated to OTA 2.2.1 and lost root....tried to root via DoRoot method again but adb never detected device....downloaded and installed Z4...it ran and kept telling me to turn USB debugging on even though it was on. Did factory reset hoping it would delete the SU files from previous root...no joy...now Z4 will run, reboot but still don't have root access. My conclusions is the Superuser files from the DoRoot are blocking the Z4 Superuser from installing....not for sure on this though.

My next gut instinct is to SBF but I don't have the 2.2.1 SBF and don't know if the one that is floating out there is for the OTA or for the leaked 2.2.1 or will it matter?

Breakthecycle2
12-12-2010, 01:12 PM
Go to settings>manage applications>z4root>clear data

Reboot. Run program..let it run for awhile. Reboot if it doesnt take and do it again. I had the same issue, and it finally worked. on the 2.2.1 .340 update.

MrSpeed3
12-12-2010, 01:26 PM
well i updated and when i launched z4 the 1st time, it didnt root. but i did a battery pull and launched z4 and it re-rooted my DX. Try doing a soft reset (battery pull while phone is on) good luck.

Btango05
12-12-2010, 01:27 PM
My gut instinct paid off! SBF'd using RSD Lite 4.8 and the 2.3.340 SBF...then ran Z4 and voila I'm rooted! I don't think I can post links to SBF downloads but if one were to google " DROID X 2.3.340 System SBF Released for 2.3.320 Leak Users" they would find the files needed.

Again I did this after OTA 2.2.1

mikeytoth
12-12-2010, 08:38 PM
No problems here also. I un rooted with z4 before I updated my x. Rerooted after with no problems and seemed to unroot faster

tycoon177
12-12-2010, 09:50 PM
Also make sure you have ian debugging on and reboot

Sent from my DROIDX using Tapatalk

wicked
12-13-2010, 01:03 AM
If it fails, try again as many times needed and it should eventually root.

grab it here http://www.droidxforums.com/forum/droid-x-hacks/13259-z4root-download-links-get-your-root-here.html

gunbound67
12-13-2010, 01:41 AM
Had the same issue just rebooted my phone and tried z4root again and worked just fine

Sent from my DROIDX using Droid X Forum App

Gerane
12-13-2010, 05:44 AM
hmm, noted, my droid x will arrive any day now, not sure which version its going to come installed with.

OnMy2ndGP
12-13-2010, 10:13 AM
I'm still on 2.3.15 but I did read somewhere that after doing the .340 OTA an reboot is mostlikely needed in order to get rooted. I'll post the thread link if I can find it again.

Still holding out on this update.....

trainedgymrat
12-13-2010, 10:47 AM
This sucks nothing seems to be working for me. I should have unrooted before the update. The superuser apk is stuck in my app drawer even though I lost root after the update. I think this is causing z4 not to work on my phone. What else should I try? I have done numerous factory resets but the super user apk is still there!!

Cigator
12-13-2010, 11:00 AM
This sucks nothing seems to be working for me. I should have unrooted before the update. The superuser apk is stuck in my app drawer even though I lost root after the update. I think this is causing z4 not to work on my phone. What else should I try? I have done numerous factory resets but the super user apk is still there!!

I unrooted before taking the update. Even so, I had a tough time getting z4 to root the X again. It would just sit there and spin. I did numerous battery pulls. I deleted z4 and reloaded a clean file. Cleaned cache, then did battery pull. Ran z4, it went through within a few minutes after that. I was about to give up if that didnt work.

joeyjackpot
12-13-2010, 11:04 AM
I had to reboot once to get z4 to work, but it works. If it doesn't work one time, that doesn't mean it doesn't work ever.

trainedgymrat
12-13-2010, 11:12 AM
I have done numerous installs, reboots, uninstalls....when I first install/reinstall z4 the app is stuck spinning, i do a battery pull, run the app again goes thru and says rebooting but still no root....what message are you supposed to get if it goes succesfully

joeyjackpot
12-13-2010, 11:14 AM
It spins for a minute and talks about trying to run the exploit - your device must be in USB debugging mode - then it "attempts to apply root" and then i don't recall if it just reboots itself after a toast message pops up or if you have to actually click like, "okay, done, reboot now" but it just turns the phone off and then when you reboot you have root. takes 1-2 minutes total. Some people report success only after up to 10 attempts.

If I were you, I would reboot my phone normally. Once. Then uninstall z4. Reboot again. Install z4. Reboot again. Then attempt it a few more times, with a reboot after each attempt.

Droid-Xer
12-13-2010, 11:17 AM
Check my sig for latest z4 and mirrors

turdbogls
12-13-2010, 11:35 AM
i flashed the SBF to get to stock 2.2.15, did the OTA, and used Z4 to get Root. i applied it right before going to bed, was it was going on 20 minutes the last time i checked it, woke up in the morning with Root...so it took AT LEAST 20 minutes for it to run and get Root. totally worth it tho. running APEX ROM and it is AMAZING.

Droid-Xer
12-13-2010, 11:39 AM
i flashed the SBF to get to stock 2.2.15, did the OTA, and used Z4 to get Root. i applied it right before going to bed, was it was going on 20 minutes the last time i checked it, woke up in the morning with Root...so it took AT LEAST 20 minutes for it to run and get Root. totally worth it tho. running APEX ROM and it is AMAZING.


Sweet, glad to hear you got it!

joe55555
12-13-2010, 01:38 PM
I tried about 10 times with z4. I cleared the data for z4, ran unroot then root and when i try to root it looks like its working then i get a white screen and it reboots but none of my apps have root access. I originally used adp to root it before this update and i tried to unroot using adp but it didnt work.

trainedgymrat
12-13-2010, 02:00 PM
this is exactly whats happening on mine as well! Hope theres a workaround im giving up for today...i already killed the battery working on this allday..

ARHicken
12-13-2010, 02:10 PM
Weird I left the root on when I updated and after the updated I was still rooted every phone is different I guess, but it took some to time to cache and catch up till I got root privileges

joe55555
12-13-2010, 03:43 PM
I think i found the problem there is two Superuser.apk files, one the old and the new one with a capital U: SuperUser.apk I am having issues getting in through a terminal program on the phone or adb to delete the old one. It keeps telling my im in read only even though i get the pound prompt and then run the mount command.

joeyjackpot
12-13-2010, 03:53 PM
U cant just delete one in Root Explorer?

Droid-Xer
12-13-2010, 04:01 PM
Hey Joey I just went from focused 1.9 to focused 1.9. There was a few steps in between though.

Everyone, be sure you're using the latest z4 downloads. Check the sig.

popwarner
12-13-2010, 04:30 PM
I ran z4 probaly a hundred times in combo with several factory resets. Flashed the 2.3.340 sbf as Btango05 mentioned(I wanted to try this sooner but I was chicken to do it before someone had success) ran z4 and got root back. Thanks Btango.

Sent from my DROIDX using Droid X Forum App

joe55555
12-13-2010, 06:44 PM
U cant just delete one in Root Explorer?


no my apps lost root access after the update.
i guess im stuck in a loop, i need root access to fix my root access.

joe55555
12-13-2010, 07:31 PM
I fixed it, I had to follow this guide:Droid X users who installed the recent 2.3 update and cannot reacquire root access; here are the steps necessary to get root (the problem is with the superuser.apk) : Android (http://www.reddit.com/r/Android/comments/el6f8/droid_x_users_who_installed_the_recent_23_update/)
once i removed the extra superuser i was able to root, thanks

trainedgymrat
12-13-2010, 07:57 PM
My gut instinct paid off! SBF'd using RSD Lite 4.8 and the 2.3.340 SBF...then ran Z4 and voila I'm rooted! I don't think I can post links to SBF downloads but if one were to google " DROID X 2.3.340 System SBF Released for 2.3.320 Leak Users" they would find the files needed.

Again I did this after OTA 2.2.1

I finally got it to work following this method!! thank you!!

jrandazzo
12-14-2010, 02:11 AM
I was one of those people who did not unroot before the last update. I lost the root, and had superuser still in my app drawer. I rooted previously with this method:

One Click Droid X Froyo ROOOOT GUI! - Droid X Rooting - AllDroid Public Board - One Click Droid X Froyo ROOOOT GUI! - Droid X Rooting - AllDroid Public Board - AllDroid.org > Home (http://alldroid.org/Default.aspx?tabid=40&g=posts&t=967&find=unread)

After I lost the root, i was unable to reroot with the same method. I just did the z4root and it installed the first try, in about 20 - 30 seconds. I guess every phone is different. Keep trying everyone!


- James

joeyjackpot
12-14-2010, 08:34 AM
Yeah. I never removed root and z4 worked fine. but i'm glad there's a workaround now for people that it didn't work for!

Droid-Xer
12-14-2010, 08:50 AM
+1 Joey, I odexed and removed bootstrap and updated & rooted fine.