PDA

View Full Version : Restoring orginal apps/Rooted DX help



macpro88
12-02-2010, 12:25 PM
I just got my DX last Friday, and being a big techie guy, I dove right into rooting my DX and getting rid of the annoying bloatware. I rooted my DX using "z4root" and following RoOoLeR's guide to Rooting. I then used "Root Explorer" to remove the bloarware, and there is where my problem is, I REMOVED it instead of renaming them to .bak. So when doing my search, I found this here (http://www.chadhaney.com/droidXDefault/), so I downloaded the .zip file of the original apps. Now my question is this, how do I restore these files to my DX to make my phone exactlly the way it was when I bought it? I tried doing a factory reset and even going into recovery mode and clearing the cache and even doing a factory reset from there. The reasoning behind wanting to do this is wanting to update to the next Android version.

Any help would be greatly appreciated.

Thank You.:reddroid:

joeyjackpot
12-02-2010, 12:28 PM
Hi there! A factory reset will never touch your system files. I'm going to type out a long answer just wanted to put something here so you'd know someone was responding while i edit :)

I had the exact same problem when upgrading from 2.1 to 2.2 - i deleted instead of renamed.

You need to get each and every APK you deleted and put it back into system/app using root explorer. Click Mount R/W (top right). then click the program file once and choose "install". it will install the package. once installed, LONG PRESS on the file and choose "Permissions". You will see a grid of permissions. Just mark them so that they appear like every other system file (you'll see rw-r--r-- next to every other system file that's already installed)

This means checking the following in the grid:

Read Write ---
Read --- ---
Read --- ---

leave unchecked where blank (---) in the permissions.

Then click save or OKAY and repeat for every app you uninstalled and you'll be good to go!

Don't forget to rename to .bak after they are installed and permissions have been set.

When you rename back to .apk for upgrade, you will not have to repeat the install/permissions process - they will be good to go once renamed.

Best of luck!

If you get a parsing error or a failed install, the apk is corrupt. Try downloading onto a PC and moving the individual APKs to your SD card via USB connection then mass moving (using multi select>move) to system/app in root explorer. I originally found a site hosting individual apks and only some worked. the .zip extracted ones all worked from the file i had.

Just make sure you're using 2.2 apks and not 2.1 or 2.1.1! :-)

Edits complete :) you should be good to go from here.

macpro88
12-02-2010, 12:31 PM
Yes, I know that now, thank you, I have all the original files in a .zip file on my computer, so how do I get those files in my /system folder on DX so my phone is like factory new? Is it true that if you delete some of the default bloatware files you will not be able to update to the next Android version?

macpro88
12-02-2010, 12:34 PM
Awesome, thank you, I will give this a try, and sorry for the quick reply lol i saw it just before you edited it

joeyjackpot
12-02-2010, 12:38 PM
No problem, i'm sure you're eager to get your device back to where it should be!

Yes, you will need every single system apk in place, installed, with the correct permissions to update. Otherwise, your updater will "fail" about a third of the way through the progress bar. That first third is checking for files - it won't even attempt to install the update if they aren't there.

I can verify from my very own phone that it's possible to delete system files and reinstall in this fashion and upgrade successfully :) you just have to make sure every darn little apk is there.

macpro88
12-02-2010, 12:47 PM
Ok, so it might be some time before I can get this done, "z4root" is not on the market anymore, and since my last factory reset, a few hours ago, I never re-synced my apps.... so now I have to root the long way? Or do you know of a way to get "z4root" back?

joeyjackpot
12-02-2010, 01:00 PM
z4root is most definitely on the market, or at least on appbrain's market! download appbrain and you'll find it, or go to z4root - Android app on AppBrain (http://www.appbrain.com/app/z4root/com.z4mod.z4root2) :)

Also, factory reset doesn't touch system files - you should still have root. you just need to redownload Root Explorer.

If you somehow lost root, just get z4 via appbrain :)

macpro88
12-02-2010, 01:31 PM
Thats odd, I could not find it on the market, I found it on appbrain, went to sync it, and it would not install! And yes, my device is unrooted, it was one of "solutions" I tired. I am just following RoOoLeR's guide to rooting because he did a great job putting it togethor and is easy to follow. Besides, got the day off from work and school, all the time in the world today.

joeyjackpot
12-02-2010, 01:40 PM
If all else fails, send me a private message with your email, or just post it here within the next 15 min.... I can email you the APK for z4 after 3pm.

macpro88
12-02-2010, 01:48 PM
Ok, DX is rooted, the apps I have are these here (http://www.chadhaney.com/droidXDefault/). Do you know if these are all legit and valid? I fould link from this guid here (http://www.droidxforums.com/forum/droid-x-hacks/8391-removing-bloat-2-2-ota-3-ways-super-easy-safe-safe-easy-free.html) on these forums.

And then all I do is unzip the folder, navigate to the appropriate folder from my DX and just install?

joeyjackpot
12-02-2010, 01:50 PM
ooh - that's where they're listed individually - i had major problems there. see if you can find a zip with all of them.... you can also try them one by one and see... i was trying this on 2.1.1, maybe these links are better for the current build.

and yes. once you download them, move them (using root explorer's multi select>move option) to system/app, then perform the install steps and permission toggles outlined above.

macpro88
12-02-2010, 02:03 PM
yes, I would like the .apk for z4root if you don't mind, i tried sending you a pm but it would not let me send it. send me a pm and ill try to respond to it.

joeyjackpot
12-02-2010, 02:14 PM
i have private messaging turned of i just realized lol. what's your email?

macpro88
12-02-2010, 02:23 PM
Ok, so I tired to send you a PM but it would not let me for some reason. I would really like the z4root .apk if its not too much trouble. Send me a PM and I will try to respond with my email address.

Also, when I copy the files over, just out of curiosity, I reinstalled one of the bloatware file (Amazon MP3), then renamed the .apk to .bak, and then I went to Apps --> Manage and it let me uninstall the app. Is this ok to do?

joeyjackpot
12-02-2010, 02:29 PM
Ok, so I tired to send you a PM but it would not let me for some reason. I would really like the z4root .apk if its not too much trouble. Send me a PM and I will try to respond with my email address.

Also, when I copy the files over, just out of curiosity, I reinstalled one of the bloatware file (Amazon MP3), then renamed the .apk to .bak, and then I went to Apps --> Manage and it let me uninstall the app. Is this ok to do?'

No - you want them installed.

You're leaving it integrated into your phone's programs, you're just removing your phones access to the target executable... that way when it goes to run it, it can't. it will also remove apps with a missing apk from your app drawer... leave installed, rename, reboot. they'll be gone and won't run again until you rename to apk and reboot...

can't do PMs - just post your email here please. you can edit it out of your post once i've copied it down.

macpro88
12-02-2010, 02:33 PM
ok cool, thank you for that info, still and android newbie here and so far love learning it!

joeyjackpot
12-02-2010, 02:34 PM
Got it.

joeyjackpot
12-02-2010, 02:37 PM
i will email within next 10-20 mins

joeyjackpot
12-02-2010, 03:02 PM
sent!

JWeathers
06-17-2011, 11:28 PM
Ok. I have a rooted Droid X running 2.2, and ignorantly deleted the bloatware instead of freezing it. Now I'm trying to restore the system apps so I can update to Gingerbread. I have the .apks on my SD card, and I've tried copying them to system/app using Root Explorer (after pressing "Mount R/W"), and it comes up with "Paste in progress..." and looks like it works. But the file is never copied. Any suggestions?