PDA

View Full Version : I need help updating from the old baseband and bootloader???!?!?!?!



chipg07
11-05-2010, 06:35 AM
Ok, here is my history with my droid X..

I bought it the day they came out at Verizon...
Brought it home, and r00ted it...
When the leaked 2.2 came out, I installed it...
I installed every rom that was released, to try them out..
When the 2.2 SBF came out, I used it to wipe the phone clean, and install my favorite rom of choice, so it was less cluttery..
During that time I have no idea, what baseband and bootloader I started off having, but here is what I have now..

Bootloader - 30.01
Baseband - BP_C_01.09.06P

I want to update to the newest bootloader and baseband, because my phone doesn't work right with some roms, and I think it is caused by one of those two.. When I install certain roms, I won't name them, they make my cell radio usage skyrocket and make my battery drain 3-4 times faster... I am convinced it's because of the baseband, which is the radio (although i know nothing about android)..

People have dismissed it as a display issue, but I have used every rom released for long enough, that if one lasts 18+ hrs on a full charge, and one doesn't last 5 hrs on a full charge, it's either something wrong with the rom, or my phone, and since other people comment how much they love the same roms that won't work right for me, I have to assume that it is my phone...

I have done everything I can think of, including trying to sbf back to 2.1 and then do the OTA update, which resulted in a brick, and having to sbf back to 2.2..

Can someone, anyone, who has any kinda clue how to update the baseband, please help me?

I appreciate all the help, but I don't need a bunch of questions about what I have tried, if I wiped, etc..... I have done ALL that ;)

Thanks in advance for any help on this subject...

Jcshannon05
11-05-2010, 09:00 AM
If it was me I would flash the newest sbf to 2.2 and go from there. And another thing... All Droids react differently to any rom. Some people get better battery life and some don't. I know it kinda sucks but u just gotta find the rom that works the best with your phone. I'm running Rubix 1.6 without any theming done. Its running fast with 5 homescreens full of Widgets.

Sent from my DROIDX using Droid X Forum App

chipg07
11-05-2010, 09:59 AM
I refuse to believe that. Same hardware, same bootloader, same kernel, same rom = same results. I will try the sbf and then ota update. Thanks.

C Dippa
11-05-2010, 10:15 AM
I refuse to believe that. Same hardware, same bootloader, same kernel, same rom = same results. I will try the sbf and then ota update. Thanks.

I updated mine the other night since I hadn't bothered to take the OTA update and was still on the leak. The 30.01 bootloader is 2.1, so you need to use the 2.1 sbf first. After flashing the 2.1 sbf, boot it up and install the OTA update. That will get you to the 30.03 bootloader in 2.2.

Edit: I see now that you say you have tried this, but 30.01 is the 2.1 bootloader, and that's the only way I know to update it.

e3zkiel
11-06-2010, 01:18 AM
What C Dippa said! He's completely correct. Only way I would know how to update those. That's what I did and I know that works.

Sent from my DROIDX using Tapatalk

chipg07
11-06-2010, 03:35 AM
Ok. I tried using the 2.1 sbf. It ran fine, finished, but then I was stuck at the bootloader with an error. Couldn't do anything.

Also, when I use the 2.2 sbf and then try the ota it says I am up to date.

chipg07
11-07-2010, 08:44 AM
Update...

I still cannot get the 2.1 sbf to work, and still have the 30.01 bootloader, and xxxxx06 baseband.

NOTHING Works.
This sucks.
2.2 sbf works fine, but won't update my bootloader and baseband.

Anyone? Bueller?

Sent from my DROIDX using Tapatalk

C Dippa
11-07-2010, 09:52 AM
Sorry to hear that man, the file I used for 2.1 was "the_gift.zip". Is that the file you've got?

If not, I'd be happy to post a link if you wanna try that one.

Sent from my DROIDX

chipg07
11-08-2010, 05:01 AM
Yes. That is the one I used. The gift.

Sent from my DROIDX using Tapatalk

ArthurIhde
11-08-2010, 06:48 AM
hmmm,thanks for the sharing.

tonyr4music
11-13-2010, 04:09 AM
I have the same issue. I try to sbf 2.1 and just hangs on the bootloader (my is 30.01 too, radio 06 like you). I can sbf 2.2 no problem but it doesn't upgrade the bootloader or baseband. Done the 2.2 sbf 9 times and the 2.1 3 times. 2.2 doesn't upgrade the bootloader or baseband and 2.1 give me an error and won't boot.

jefflikesbagels
11-13-2010, 08:47 PM
For what it's worth, I had never flashed the 2.2 SBF, and I've been running on RubiX for awhile. I went from 2.1u1 to 2.3.9 leak to 2.9.13 leak to 2.9.15 leak to RubiX (this was over a long period of time lol). Recently I decided to try and upgrade the bootloader and baseband. I simply flashed the 2.1 SBF, wiped data and cache, and it booted up no problem. Then I let the software update run to get to 2.2 OTA, then I rooted and flashed my RubiX backup. Everything worked.

I think the main problem is when you guys flash the 2.2 SBF before you flash the 2.1 SBF. I'm not sure how you guys can get around this issue.

mitchuscg
11-13-2010, 09:38 PM
actually on 2.1 the bootloader was 29.01. or it was for me. i tried updating it when 2.2 came out and it bricked mine. so i got a new one on 2.1 and updated it and it says 30.03. i dont think the sbf gives you the most recent bootloader.